9 Replies Latest reply: May 8, 2013 9:19 AM by JRx RSS

    Photoshop opens all files as transparent

    JRx

      I installed the CS4 Suite. When Photoshop comes up the background layer is transparent. This happens even if I open a file with Photoshop. In that case, the Layer icon shows the image but what I see on screen is only the checkerboard pattern. The proper way for the New file to show up is with the background a solid (specified) color and for an opened file the actual image being opened.  How do I correct this?

       

        • 1. Re: Photoshop opens all files as transparent
          Chris Cox Adobe Employee

          Update your video card driver from the GPU maker's website, or turn off GPU drawing in Photoshop preferences.

          • 2. Re: Photoshop opens all files as transparent
            JRx Community Member

            My (NVDIA) video card driver is updated. This program has run fine in my last computer using this same video card before it was updated. In order to check if this was a problem I reinstalled Photoshop CS2 on this computer. Photoshop CS2 opened correctly (with either a [New] blank opaque page or a [Open] opaque page showing the image I opened.

            • 3. Re: Photoshop opens all files as transparent
              Chris Cox Adobe Employee

              CS2 doesn't use the GPU.

               

              Again, this is a bug in your video card driver.  To fix it, you need to update your video card driver.

              Temporarily, you could disable GPU drawing in Photoshop's preferences.

              • 4. Re: Photoshop opens all files as transparent
                JRx Community Member

                 

                Thanks. Do the other programs in the CS4 suite (Illustrator, InDesign) use the GPU as well?

                 

                • 5. Re: Photoshop opens all files as transparent
                  JRx Community Member

                  Also, can you please describe IN DETAIL how to a) get to, and b) "deactivate GPU drawing in Photoshop preferences".  Thanks

                   

                  • 6. Re: Photoshop opens all files as transparent
                    Curt Y Community Member

                    GPU can be disabled in PS edit/preferences probably in performance tab section.

                    • 7. Re: Photoshop opens all files as transparent
                      JRx Community Member

                      In Photoshop Edit/Preferences there is a GPU Settings area listing my “NVIDIA Corporation Quadro NVS 285/PCIe/SSE2”  graphics card and showing the “Enable OpenGL Drawing” checked. (There is also an [Advanced Settings…] button with various GL Settings activated.) However it is not until I uncheck Enable OpenGL Drawing that I can see an image when I open up an existing .psd file—otherwise it shows up as a transparent area (checkerboard pattern) with the image showing only in the (Background) Layer Icon.

                       

                      I have updated the driver for the NVIDIA Quadro NVS 285 with the Quadro/Tesla Desktop Driver Release 304     [ http://www.nvidia.com/object/quadro-tesla-win8-win7-winvista-64bit-307.45-whql-driver.html   ]

                       

                      Because Photoshop accurately recognizes and lists my graphics card in its Preferences settings (and because I am using the latest driver release for that card) I must assume Photoshop has recognized and accepted my NVIDIA graphics card.

                       

                      So the question remains, given that Photoshop recognizes the graphics card and the graphics card driver has been up dated (OS: Win7 Professional):

                          a)    What is Photoshop needing now?    And

                          b)    What can I do to Enable OpenGL Drawing?

                      • 8. Re: Photoshop opens all files as transparent
                        Noel Carboni Community Member

                        Your GPU isn't really sufficient to run Photoshop.  Just about any video card you can buy to replace it is better than that ancient circa 2006 video card.

                         

                        Do yourself a favor - don't waste any more of your time trying to make it work.  Go down to the local high tech store and get an inexpensive gamer card.  Go through whatever process is necessary to fully remove the old drivers, get the latest released new drivers for the new card, and be happy.

                         

                        -Noel

                        • 9. Re: Photoshop opens all files as transparent
                          JRx Community Member

                          Point taken.   When building this computer I originally had a gamers video card (I am NOT a gamer)--one employing an Eyefinity approach--that I had to return for incompatibility purposes.

                           

                          I believe my original concerns were all addressed in this thread. Rather than continue, I would like to post a new thread discussing inexpensive graphics card options and what advantage there is to using OpenGL Drawing.

                           

                          Can someone mark this thread completed.

                           

                          Thanks to all who contributed.