3 Replies Latest reply on Jan 17, 2015 10:00 PM by Steve B11

    Library book needs 'Vendor ID' authorization

    erica hailstone

      Hello, I have succesfully borrowed a book from the e-book collection of the Library of Wales.  It seems to be there on my computer in Adobe Digital Editions, and I have followed all the instructions regarding authorizing the computer for ADE and the device (Nook) for ADE. However I keep getting the message 'this computer needs to be authorized with a vendor ID to open  (the item)'.

      What is a vendor ID and how do I get it.

      Also the pop up box shows the line for Vendor ID greyed out with 'Adobe ID' in instead

      what do I do?

      thanks for any help, this is most frustrating!

        • 1. Re: Library book needs 'Vendor ID' authorization
          screed1

          I have the same problem.  It would be nice if Adobe would address it.

          • 2. Re: Library book needs 'Vendor ID' authorization
            thisisbullshit

            I have this problem too. I went on to Adobe chat, and they refused to tell me what to do about the vendor ID. They told me to go to the Adobe help site, but I see no reference to this problem. I just want to download some library books to my ereader. The person on chat basically said that, since ADE is free, there is no chat support available. What a crock.

            • 3. Re: Library book needs 'Vendor ID' authorization
              Steve B11 Level 1

              Don't you think it's about time somebody responded to this kind of problem?

               

              The whole ADE business is a f'ng disgrace, with every roadblock known to man being thrown up when you try to "authorize" a computer. I've just tried to change a computer's authorization to be associated with an Adobe ID, and all I get is the message "You can only authorize this computer with an Adobe ID that hasn't been previously used to authorize any other computer or mobile devices. Please try again."

               

              Of course if you are dumb enough to try again, you get the same result, over and over.

               

              A computer died, I replaced it, now I'm getting this crap and wasting hours of my time.

               

              As I said, a f***ing disgrace.