4 Replies Latest reply on May 13, 2013 9:22 AM by CDean

    Scrambled MXF Footage in Premiere?

    CDean

      Hi there,

       

      I'm having an issue with Premiere scrambling some MXF files after it's been imported. I have already read alot about how Premiere has some issues with MXF files from Canon C300 and XF3405 etc (which I have indeed used) but I haven't seen anyone mention the specific problems that I'm having. I'll explain my whole process below...

       

      I have copied all of my data onto an external drive, preserving the Flash card's internal file structure. I attempted to import them directly to Premiere using the Media Browser, and although the files import, and the audio plays back fine and at correct speed, this is all I see:

      Screen Shot 2013-05-13 at 11.36.01.png

       

      After reading alot on this site, I figured that maybe I was experiencing the same issues as everyone else regarding Canon footage, and heard of a workaround using Canon XF Utility. I downloaded it, installed it and can play back footage *perfectly* inside that program. So I then exported a series of MXF files from there and re-imported them into Premiere.....with the exact same result.

       

      My initial thoughts are that as a noob, I've incorrectly setup Premiere to deal with this type of footage. Has anyone else had a similar experience or know what's going on? Any ideas/suggestions would be much appreciated.

       

      Using a Macbook Pro 15" Retina, with up to date version of Premiere and OS.

      16 GB RAM

      NVIDIA GeForce GT 650M 1024 MB

        • 1. Re: Scrambled MXF Footage in Premiere?
          Trevor.Dennis Adobe Community Professional (Moderator)

          Gibran, I've always bought my XF300 footage in directly, and never use XF Utility.  I move the entire directory into a named folder, search that folder for .MXF files, and move them out of their individual folders into the main folder.  This has always worked for me.  I just can't think why I would need the original file structure, but I keep those folders so I can rebuild if I ever need to.  This has never given me the slightest problem in PP CS6 running on a Windows 7 PC, and originally also worked fine with After Effects.  AE suddenly stopped accepting those MXF files a couple of months ago, and won't play previous projects that used MXF files.  I thought the MXF issue was only with After Effects.

          • 2. Re: Scrambled MXF Footage in Premiere?
            CDean Level 1

            Trevor, I was only going on the numerous threads posted on this forum which listed errors with MXF files. True, alot of them were from last year but it's the first thing that jumped out at me when I went online to look for more information. I agree with you in one sense- I've had the same results whether I imported directly or through using Canon XF Utility. However, the footage works fine in that program and even works okay in Prelude.

             

            It's this weird scrambling which is the confusing and annoying part...

            • 3. Re: Scrambled MXF Footage in Premiere?
              UlfLaursen Level 2

              I import from my Canon XF's via the media browser without problems into CS6 (6.03). Before 6.02 I had the "shearing" issue on my files, but for a long time, I have had no problems at all, and I have never seen what you experience - sorry.

               

              Ulf

              • 4. Re: Scrambled MXF Footage in Premiere?
                CDean Level 1

                UPDATE: Problem mysteriously solved....

                 

                I opened up an old project that didn't contain any MXF files while speaking to a technical support team member, and when I re-opened my latest project, the files were magically fixed. No clue why. I changed no settings and didn't import the footage in any different way.

                 

                The technical support member wasn't sure why either but suggested it may have been a display issue, and that it was best to ensure I had the latest drivers installed. Sound advice but a bit confusing as to why the errors occurred and why they went away!? A display issue makes sense but I made no settings changes at all, so confused as to how it fixed itself.

                 

                Anyhoo, back to the simple task of editing it!