4 Replies Latest reply on Sep 22, 2006 7:30 AM by zydecode

    CSS Editor in Eclipse hijacked/disabled

    zydecode
      Flex sets itself as the default CSS editor in Eclipse, whihc is fine.. except that I prefer the WST CSS editor that is installed with the WST toolkit that you can get from Eclipse.org.

      So.. going to "Preferences>General>Editors>File Associations" I can set the default CSS editor back to the WST CSS editor, and even delete the Flex CSS editor - but doing that just gives me "plain text" css files (black font, no code completion, Outline View etc).

      But - if I go into "Help>Manage Configuration" and DISABLE Flex - I get my CSS editor back!

      SO - does anyone know how I can have Flex ENABELD *and* have my referred CSS editor..?

      Cheers,

      Sean
        • 1. Re: CSS Editor in Eclipse hijacked/disabled
          Level 7
          zydecode wrote:
          > Flex sets itself as the default CSS editor in Eclipse, whihc is fine.. except
          > that I prefer the WST CSS editor that is installed with the WST toolkit that
          > you can get from Eclipse.org.
          >
          > So.. going to "Preferences>General>Editors>File Associations" I can set the
          > default CSS editor back to the WST CSS editor, and even delete the Flex CSS
          > editor - but doing that just gives me "plain text" css files (black font, no
          > code completion, Outline View etc).
          >
          > But - if I go into "Help>Manage Configuration" and DISABLE Flex - I get my CSS
          > editor back!
          >
          > SO - does anyone know how I can have Flex ENABELD *and* have my referred CSS
          > editor..?

          I don't know if this is the problem, but Eclipse remembers the last
          editor used to open a file. So, if you have a file called foo.css and
          open it with the Flex CSS editor, that file will open with the Flex CSS
          editor the next time you open it even if you have changed the file
          association for .css files. But files that you haven't opened before
          should open with the editor specified by the fila associations.

          Here's something to try: Right-click on your CSS file and choose the WST
          editor from the "Open With" submenu. That file should then open with the
          WST editor on subsequent openings.

          -- Greg Dow
          -- Adobe Flex Builder Team
          • 2. Re: CSS Editor in Eclipse hijacked/disabled
            zydecode Level 1
            Greg,

            thanks for the reply. I have tried all your suggestions, as well as:
            - re-installing the complete WST package
            - deleting the FLEX CSS editor from the choices available in Preferences>General>Editors>File Associations" for .css

            and the ONLY thing that works is to DISABLE Flex.

            SO.. I'm inclined to put this in the "This is a Bug" category. It does seem to be Flex that is causing this issue; I use Eclipse for all my coding and have several otrher plugins installed (JSEclipse, Zend IDE, Azzurri Clay) and have worked with PHPeclipse and several other plugins that offered their own editors - but none so completely hijacked a file association as Flex has with .css.

            Of course - if Flex's CSS editor was as good as the WST toolkit one, I wouldn't mind as much ;o)

            Cheers,

            Sean
            • 3. Re: CSS Editor in Eclipse hijacked/disabled
              RedWylie
              Have you found a solution to this, it drives me crazy too.
              • 4. Re: CSS Editor in Eclipse hijacked/disabled
                zydecode Level 1
                heh.. well, yeah, I found a solution, but it's more just a resigned acceptance of a bad situation, really :oP

                Basically, I have ended up with two installations for Eclipse - I do my PHP/HTML coding using the new Zend PHP-IDE plugin, which *ONLY* runs in Eclipse 3.2. SInce the Flex plugin CAN'T run on 3.2, I now have both 3.2 and 3.1 installed - so Flex taking over the CSS in 3.1 doesn't affect me anymore.

                However - this solution means I may as well just have installed the Flex builder, not the Eclipse plugin :oP

                Cheers,

                Sean