6 Replies Latest reply on May 23, 2013 11:12 PM by pwillener

    HELP

    takilindsay

      My computer is a Mac OS X version 10.5.8, processor 1.8 GHz PowerPC G5. Everytime I click on 'get adobe flash player', it takes me straight to 'install a different version of Adobe flash player'. There are 2 options in the pop up box 'select an operating system' which are Mac OS X 10.6-10.8 and Mac OS X 10.4-10.5. When I download Mac OS X 10.6-10.8, it says it cant be installed because its not supported on this architicture and when I download the other one it says 'cant be installed . Devices with PowerPc processors are no longer supported. Click below to download the last version of flash player for PowerPC. I do that and it just takes me back to the beginning. Please help me