11 Replies Latest reply on Oct 25, 2007 7:52 AM by eddiwil9

    QT not working on Windows

    eddiwil9
      I have some QT movies (only audio portions) that I need to use for a project. The PC I am working on will play the QT Files with the QT player, but they do NOT pay (or even show up (controller) in Director at all (both in the Director file and the Projector.

      I chose all of the QT xtras,but that did not help.

      Any help is appreciated.


        • 1. Re: QT not working on Windows
          CarrieBey
          Are you able to import? If not, what is the error message.
          You say they don't play, what happens? If there is a red box with an x through it, you may need an upgrade for your Quicktime player.
          Do you have a way to convert the audio files to a different format and use that way?
          • 2. Re: QT not working on Windows
            eddiwil9 Level 1
            Yes, I can import the file. I just can't see anything (like the controller, which I have set to display). It doesn't play, doesn't do anything. There is no red "X" like when you don't have an xtension loaded... just nothing at all.

            Quicktime plays with no problems on the computer. It just doesn't play when imported into Director. I have never seen this happen before... very strange.

            I wouldn't mind converting the file, but I need to be able to FF and REW the file (as with the QT controller). I don't think I can easily do that with any other file type. QT should work simply; no idea what's up!
            • 3. QT not working on Windows
              eddiwil9 Level 1
              I am thinking it is an issue with QT on Windows... imagine that!

              I went back to a Director file I made several years ago (QT 4!). The QT won't play there either, though the files play on the machine if played directly withthe QT player.
              • 4. Re: QT not working on Windows
                Level 7
                eddiwil9 wrote:
                > I am thinking it is an issue with QT on Windows... imagine that!
                >
                > I went back to a Director file I made several years ago (QT 4!). The
                > QT won't play there either, though the files play on the machine if
                > played directly.

                You could try going to the QT control panel and, under the "Advanced" tab,
                changing the video to "Safe mode".

                Or you could try switching off hardware acceleration in the Display
                Properties control panel (under the Troubleshooting tab).

                You are trying to play the video on the same monitor as the one it works on
                in the QT player, aren't you? Some video cards may not like playing video on
                a secondary display.

                Can you install an earlier version of QT and try that?

                Andrew


                • 5. Re: QT not working on Windows
                  eddiwil9 Level 1
                  Thanks, Andrew. I will give that a try now.

                  All is on the same monitor. I did go back-- even went all the way to QT version 4! I have never seen an issue like this .. very odd!
                  • 6. Re: QT not working on Windows
                    eddiwil9 Level 1
                    Changed the setting to "Safe Mode," but it made no difference. Also, could not find any place to turn off HW acceleration. Found all the properties for the Intel GMA Driver, but no way to turn Off/On.
                    • 7. Re: QT not working on Windows
                      Level 7
                      eddiwil9 wrote:
                      > Changed the setting to "Safe Mode," but it made no difference.
                      > Also, could not find any place to turn off HW acceleration. Found all
                      > the properties for the Intel GMA Driver, but no way to turn Off/On.

                      Silly me! I didn't notice in your first post you'd said "audio only". Does
                      changing the Audio settings in the QT control panel make any difference?

                      Also, maybe setting "the soundKeepDevice=false" will help. Actually, try
                      that first.

                      Andrew


                      • 8. Re: QT not working on Windows
                        eddiwil9 Level 1
                        I'll give that a shot.

                        It's not just the audio files.. I have tried handful of QT files now... some mine, some external. Just audio, just video,and some with both. Same thing. They seem to "not exist" in Director, but play just fine "normally."
                        • 9. Re: QT not working on Windows
                          SafariTECH Level 1
                          If it is just audio, and you have no need for video, you will likely be much better off converting them to SWA which will play natively within Director under its own sound control.

                          Just my 2 cents worth.

                          On the PC, what player is set to play MOV files by default? If it is not QT then that is possibly the issue - the OS is trying to use the default player.

                          What codec is being used? I ask, because for Windows Media files, it actually does not play with the base WMP, but rather the older rudimentary Mplayer which does not support anything but the basic codecs ... possibly this is a similar issue ?
                          • 10. QT not working on Windows
                            liveoak Level 1
                            quote:

                            Originally posted by: Newsgroup User
                            eddiwil9 wrote:
                            Or you could try switching off hardware acceleration in the Display
                            Properties control panel (under the Troubleshooting tab).

                            To agree with this post, I have been forced to recommend to quite a few users (more than previous years) to turn off hardware acceleration in the last few months when they have QT issues with audio as well as with video. Not entirely sure what is up, but this seems to be a temporary solution for my users.
                            • 11. Re: QT not working on Windows
                              eddiwil9 Level 1
                              Agreed the other sound formats work well, BUT, I must have the FFW/REW feature of the QT controller. If any of the other methods would do that, I would use them (I mean easily/simply display a controller bar for scrubbing).

                              I decided to upgrade to the most recent version of QT-- WORKS GREAT. QT files show up and play perfectly in Director. Unfortunately, the enterprise-wide IT dept. won't upgrade all 800+ users to the most recent version. Odd that the recent version works and the older versions do not (and this is with files with creation dates that span years and multiple QT versions!) .

                              This makes me think it's some kind of wacky QT on Windows install issue and not a Director issue at all.