3 Replies Latest reply on May 20, 2013 3:09 PM by Peter Spier

    Spell check misses?

    michelle e Level 1

      I have noticed  lately that spell check is flagging a few words that should be OK. This has happened in more than one document. In my current document, it flagged "benefits" and "specific." My InDesign preference's dictionary language is set to English: USA, there are no character style sheets applied to the text, and the paragraph style sheet setting (which is applied) has the language set to English: USA (there are no overrides). The Check Spelling window also shows the language is set to English: USA when it is open.

       

      I have restarted InDesign (v7.0.4), and made sure there are no outstanding updates to any Adobe software on this machine. I also made sure the system software is updated (Mac OS 10.6.8). I opened the same document on another machine which is running Mac OS 10.7.5 and InDesign v8.0.1, and got the same results when I checked spelling.

       

      The document has six pages with plenty of text, so the fact that just two words are flagged seems weird. I would expect most words would be flagged if there was something awry with the dictionary. So I created a new document and made a text box containing the sentence "The benefits are specific." When I checked spelling, there were no flags! The problem document was received from a client in CS5 format.

        • 1. Re: Spell check misses?
          FergyMac Level 3

          It's possible the flagged words are using f-i ligatures so the spell check doesn't see them as "benefits" and "specific", it reads them as "bene#ts" and "speci#c".

          • 2. Re: Spell check misses?
            michelle e Level 1

            Thanks FergyMac,

             

            Ligatures had crossed my mind, but when I zoomed in to the words, the letters didn't look like ligatures, and the output proof didn't show ligatures. After reading your post I retyped the words and the spell check didn't flag them—even though they looked the same as before. Then I realized that the Frutiger font may be the culprit. When I selected the text (after reverting the document so my retyping wasn't saved) and changed it to Garamond (sans serif), I could see the ligatures!

            • 3. Re: Spell check misses?
              Peter Spier Most Valuable Participant (Moderator)

              It might also have been the language. The settings in the prefs have nothing to do with the language assigned to text, only the choice of dictionary to be used for each language when more than one dictionary is available. Language itself is a character-level attribute assigned either as part of the style or by selecting a language from the dropdown in the Character panel or Control panel.