3 Replies Latest reply on May 30, 2013 3:38 PM by sjpt

    Updated ADE doesn't recognise AdobeID

    ChrisR_UK

      Just updated to the latest version of ADE - wish I hadn't bothered.  The new version doesn't recognise the Adobe authorisation.  I deleted the old authorisation and re-authorised (not a straightforward process as there is little information available - and none at all within the program menus).  Then I connected my Sony reader to the Sony software, only to be told that the authorisation on the reader was different, and I could not transfer my library book across to it.  I had to reconnect the Sony to ADE, de-authorise the reader and re-authorise it.  I then still couldn't read the book, and I had to download it again from the public library.  In the process I noticed that my reader was still using my old email address on its authorisation (which has been working happily for several years). 

      When I contacted Adobe several years ago - on changing my email address - I was assured that an Adobe ID was based on the number, not the email address, but it appears that all devices use the email address first and foremost.  Luckily I have never bothered buying any books - just have the many free books that came with the reader, and library books.  If I had had a load of purchased books and found I had to download them all again I would have been livid.

      This just isn't good enough.  A company as large as Adobe should be able to create an update to a program that finds the registration details from the previous version, without expecting the user to faff about.  Also, if they say an ID is based on the unique number, then that is what they should use - not the email address  - for checking validity.  The whole system is a shambles, and Adobe should be ashamed of the dire quality of their products. 

      To add insult to injury is now impossible to send an email to Adobe - you just get page not found if you try the Contact Us page.  ILLEGAL in the UK I should point out - it is a legal requirement for anyone selling from a website in the UK to have a valid email address to allow customers to contact you.  SORT IT OUT ADOBE!!

        • 1. Re: Updated ADE doesn't recognise AdobeID
          sjpt Level 4

          The whole system is a shambles, and Adobe should be ashamed of the dire quality of their products. Absolutely.  At least of the implementation of the ADEPT infrastructure, and in particular of ADE2.0.

           

          I never had much luck with my Sony (PRS-350) and ADE2.0.  It worked for bought books, but completely failed with Overdrive library books.

          The solution was to revert to v1.7.2; that seems to be the solution for lots of people with many different kinds of problems on ADE2.0.

           

          Failure to carry the registration between versions is very bad.

          As you mentioned, it often manages to get itself half-registered and needs de-registering by the ctrl-shift-D trick (completely undiscoverabe within the code).

           

          ~~~~

          One thing though is that the AdobeID really is based on an internal guid.

          If you open a DRM book as a zip file and look in the embedded file rights.xml, you will see a section like

          <user>urn:uuid:ff2ddc22-eca0-46c6-a84d-390cxxxxxxxx</user>.

          If you ask ADE2.0 for your information (ctrl-shift-I or Help/Authorization Information) you should see the same guid,

          as well as the email address it last knew about being registered with this id.

           

          Systems sometimes report the old email address, but the 'true' registration is with that guid and not with the email address.

          It may be the issues you are having with the Sony is due to the ADE2.0/Sony/Overdrive incompatibility.

          Try reinstalling v1.7.2 and using that ~ you can have both version installed at once if you like.

           

          In case you've lost the install file for 1.7.2.

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

          1 person found this helpful
          • 2. Re: Updated ADE doesn't recognise AdobeID
            ChrisR_UK Level 1

            The plot thickens....decided my eyes could no longer take the strain of my Sony in artificial light, and with the cheap deals being offered by Barnes and Noble, decided to invest in a Nook.  All was well until I tried to download a book from the library and install it on the Nook.  Once again ADE 2 refused to co-operate.  I got the book from the library, and managed to download it to the Sony, but ADE couldn't authorise the Nook.  I tried everything I could find on the web....including deleting the ADE files off the Nook, but whatever I did it would not work.  Finally, in desperation, I uninstalled ADE 2, hunted round for the older version (1.7 ?) and installed that instead.  It came up, spotted my Nook (which I had accidentally left plugged in), said "Do you want me to authorise this?" (or words to that effect) and I clicked yes and away we went.  One Nook duly authorised and now displaying my library book.

            The moral of this story....ditch ADE 2 and stick with the old version.  (I am running on Vista, the Sony is an old PRS-600 and the Nook is the Simple Touch Glowlight).

             

            If anyone from Adobe is reading this forum...PLEASE, PLEASE no more versions of ADE unless you test them thoroughly and make sure they work before launching them on an unsuspecting customer base.

            • 3. Re: Updated ADE doesn't recognise AdobeID
              sjpt Level 4

              PLEASE, PLEASE no more versions of ADE unless you test them thoroughly and make sure they work before launching them on an unsuspecting customer base.

               

              Seconded