6 Replies Latest reply on Nov 14, 2013 12:10 PM by SueBachanDobe

    Problems installing CF 10 with Apache 2.2.24 (or 2.4) on RHEL 6.4

    SueBachanDobe

      Built Apache using openssl 1.0.1e (updated LD_LIBRARY_PATH to reflect the correct openssl libs) and pcre. Configure for build was:

      configure --enable-ssl=shared --with-ssl=/usr/local/ssl  --enable-so --with-included-apr --with-pcre  --with-perl

      Also downloaded and built the connector from http://helpx.adobe.com/coldfusion/kb/rhel-connector-configuration.html after the vanilla CF install didn't work. I get the following when I try to start up CF:

      [root@web01 logs]# /etc/rc.d/init.d/coldfusion_10 start

      Starting ColdFusion 10 server instance named cfusion ...

      The ColdFusion 10 server instance named cfusion is starting up and will be available shortly.

      nohup: appending output to `nohup.out'

      ======================================================================

      Running the ColdFusion 10 connector wizard

      ======================================================================

      Configuring the web server connector (Launched on the first run of the ColdFusion 10 start script)

      Running /usr/local/apache2/conf connector wizard...

      =======================================

      There was an error while running the connector wizard

      Connector installation was not successful

      =======================================

      ======================================================================

      ColdFusion 10 server instance named cfusion has been started.

      ColdFusion 10 will write logs to /opt/coldfusion10/cfusion/logs/coldfusion-out.log

      ======================================================================

       

      The wsconfig.log contains the following:

      [root@web01 wsconfig]# cat wsconfig.log

      # Created by ColdFusion on 05/28 15:15:23

      05/28 15:15:23 info Tomcat Connector

      05/28 15:15:23 debug command line: -ws Apache -bin /usr/local/apache2/bin/httpd -script /usr/local/apache2/bin/apachectl -dir /usr/local/apache2/conf -v

      05/28 15:15:23 info Red Hat Enterprise Linux Server release 6.4 (Santiago)

      05/28 15:15:23 debug Using Apache binary /usr/local/apache2/bin/httpd

      05/28 15:15:23 info Server's Module Magic Number: 20051115:31.  Supported major magic numbers on this platform are 20020628 and 20020903.

      05/28 15:15:23 info Attempting to build connector from sources

      05/28 15:15:23 info Server version: Apache/2.2.24 (Unix)

      05/28 15:15:23 debug Using Apache control script /usr/local/apache2/bin/apachectl

      05/28 15:15:23 debug Parsing Apache configuration file /usr/local/apache2/conf/httpd.conf

      05/28 15:15:23 debug Exec'ing chmod 777 /opt/coldfusion10/config/wsconfig/1

      05/28 15:15:23 debug Set permission to 777 on /opt/coldfusion10/config/wsconfig/1

      05/28 15:15:23 debug Exec'ing chmod +x /opt/coldfusion10/config/wsconfig/1/mod_jk.so

      05/28 15:15:23 debug Set permission to execute on /opt/coldfusion10/config/wsconfig/1/mod_jk.so

      05/28 15:15:23 debug Created file /opt/coldfusion10/config/wsconfig/1/mod_jk.so

      05/28 15:15:23 debug Wrote file /usr/local/apache2/conf/httpd.conf

      05/28 15:15:23 debug Added ColdFusion configuration to Apache configuration file /usr/local/apache2/conf/httpd.conf

      05/28 15:15:23 debug Created file /opt/coldfusion10/config/wsconfig/1/README.txt

      05/28 15:15:23 debug Wrote file /opt/coldfusion10/config/wsconfig/wsconfig.properties

      05/28 15:15:23 debug Exec'ing /usr/local/apache2/bin/apachectl restart

      05/28 15:15:23 error Error running "/usr/local/apache2/bin/apachectl restart": exit code was 1

      05/28 15:15:23 error Error restarting Apache server.  The web server must be restarted to complete this operation.

      com.adobe.coldfusion.connector.connectorinstaller.WebServerException: Error restarting Apache server.  The web server must be restarted to complete this operation.

          at com.adobe.coldfusion.connector.connectorinstaller.ApacheInstaller.restartWS(ApacheInstall er.java:480)

          at com.adobe.coldfusion.connector.connectorinstaller.ApacheInstaller.installConnector(Apache Installer.java:269)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.installConnector(Con nectorInstaller.java:340)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstal ler.java:284)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstal ler.java:741)

       

      05/28 15:16:37 info Tomcat Connector

      05/28 15:16:37 debug command line: -ws Apache -dir /usr/local/apache2/conf -bin /usr/local/apache2/bin/httpd -script /usr/local/apache2/bin/apachectl -cfide /opt/coldfusion10/cfusion/wwwroot/CFIDE -v

      05/28 15:16:37 error This web server is already configured for ColdFusion.

      com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstallerException: This web server is already configured for ColdFusion.

          at com.adobe.coldfusion.connector.connectorinstaller.ApacheInstaller.installConnector(Apache Installer.java:187)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.installConnector(Con nectorInstaller.java:340)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstal ler.java:284)

          at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstal ler.java:741)

       

      I've searched and tried just about everything I could find relating to the error info.