3 Replies Latest reply on May 31, 2013 12:34 AM by pwillener

    Flash player detected as installed but not playing movies

    slam_02

      Hi,

       

      I've been struggling with that problem since a yesterday. I do not know what is my next move, so I'm seeking help here.

       

      Problem:

      Since a couple of month, everytime there was a firefox or a flash player update, the flash player was not working anymore within firefox. Usually, turning the addon off and back on was working and life goes on.

       

      Not since yesterday (may 28, 2013). There was a firefox update (v 21.0) and now I can't make it work anymore.

       

      For example, when I go on youtube, the screen stays blank. Nothing happens.

      If I go on grooveshark.com, after a couple of seconds, I have the folliowing warning: "We had a problem loading Adobe Flash. You may have a Flash blocker installed.  If so, please disable the blocker (or add an exception) and reload to start listening." I have no 'blocker' (although I do not really know what they are referring to).

       

      My system:
      Windows7 Enterprise 64b

      12g ram

      firefox21.0

       

      Here's what I tried (in no particular order since I do not remember all I did... ):

       

      1. Do I have the latest flash installed?
      http://www.adobe.com/software/flash/about/
      Yes. 11.7.700.202 at the moment.

       

      2. Is it working fine?
      http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html
      I do not see the movie, but I see the flash/os/browser version in step 2.

       

      3. Uninstall flash

      http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

       

      4. Resinstall latest flash

      http://get2.adobe.com/flashplayer/

       

      5. Try firefox in safe mode

      http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

       

      6. uninstall flash (again) uninstall firefox

       

      7. reinstall firefox 21

      http://www.mozilla.org/en-US/firefox/new/

       

      8. reinstall flash

      http://get2.adobe.com/flashplayer/

       

      9.  Try firefox in safe AND with a new profile

      http://forums.adobe.com/thread/1018071

       

      10. Tried Process monitor to figure out what was the problem. Inconclusive for me.

      I have the log file, but I can't find how to attach a file on the forum. Maybe I can send  it by mail to someone?

       

      It always ends up with the following:

      8:23:37.8014358 AMFlashPlayerPlugin_11_7_700_202.exe7452Thread Create
      SUCCESSThread ID: 7068
      8:23:37.8016548 AMFlashPlayerPlugin_11_7_700_202.exe7452Thread Create
      SUCCESSThread ID: 7620
      8:23:38.8404259 AMFlashPlayerPlugin_11_7_700_202.exe4068Thread Create
      SUCCESSThread ID: 6676
      8:23:38.8405789 AMFlashPlayerPlugin_11_7_700_202.exe4068Thread Create
      SUCCESSThread ID: 2384
      8:24:44.8008095 AMFlashPlayerPlugin_11_7_700_202.exe7452Thread Exit
      SUCCESSThread ID: 7068, User Time: 0.0000000, Kernel Time: 0.0000000
      8:24:45.8398261 AMFlashPlayerPlugin_11_7_700_202.exe4068Thread Exit
      SUCCESSThread ID: 6676, User Time: 0.0000000, Kernel Time: 0.0000000
      8:25:14.7997270 AMFlashPlayerPlugin_11_7_700_202.exe7452Thread Exit
      SUCCESSThread ID: 7048, User Time: 0.0000000, Kernel Time: 0.0624004
      8:25:14.7998261 AMFlashPlayerPlugin_11_7_700_202.exe7452Thread Exit
      SUCCESSThread ID: 7620, User Time: 0.0000000, Kernel Time: 0.0000000
      8:25:15.8390652 AMFlashPlayerPlugin_11_7_700_202.exe4068Thread Exit
      SUCCESSThread ID: 2384, User Time: 0.0000000, Kernel Time: 0.0000000
      8:25:15.8391476 AMFlashPlayerPlugin_11_7_700_202.exe4068Thread Exit
      SUCCESSThread ID: 7076, User Time: 0.0000000, Kernel Time: 0.0000000

       

      There is no action between the Thread create and thread exit? That seems weird to me.

       

       

      Todo:

      11. debug with WinDbg (but I'd rather not get there since I'm not very sed to WinDbg)

       

       

      Some things I noticed:

      When I kill the flash process withinin the task manager, firefox detects it as if it has crash and display the problem error message.

      It works fine in IE8 and Chrome

       

      Does anyone has a clue on how to help me?

       

      Thank you.

       

      Also, here's the two last entry in my FlashInstall.log file:

      =O====== M/11.7.700.202 2013-05-28+19-08-27.001 ========

      0000 [I] 00000010 "C:\Users\jflavoie\Desktop\uninstall_flash_player.exe" -force 

      0001 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0002 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0003 [W] 00001018

      0004 [W] 00001037 Software\Macromedia\FlashPlayer\SafeVersions/ 2

      0005 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX/ 2

      0006 [W] 00001019

      0007 [W] 00001020

      0008 [W] 00001037 Software\Microsoft\Windows\CurrentVersion\RunOnce/FlashPlayerUpdate 2

      0009 [W] 00001037 Software\Macromedia\FlashPlayerActiveX/ 2

      0010 [W] 00001037 Software\Macromedia\FlashPlayer/FlashPlayerVersion 2

      0011 [W] 00001037 Software\Macromedia\FlashPlayer/SwfInstall 2

      0012 [W] 00001037 Software\Microsoft\Code Store Database\Distribution Units\{D27CDB6E-AE6D-11CF-96B8-444553540000}/ 2

      0013 [W] 00001021

      0014 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0015 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0016 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0017 [W] 00001037 Software\Microsoft\Windows\CurrentVersion\RunOnce/FlashPlayerUpdate 2

      0018 [W] 00001037 Software\Macromedia\FlashPlayerPlugin/ 2

      0019 [W] 00001037 Software\Macromedia\FlashPlayer/FlashPlayerVersion 2

      0020 [W] 00001037 Software\Macromedia\FlashPlayer/SwfInstall 2

      0021 [W] 00001021

      0022 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0023 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

      0024 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0025 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

      0026 [W] 00001037 Software\Microsoft\Windows\CurrentVersion\Control Panel\Extended Properties\System.ControlPanel.Category/C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl 2

      0027 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0028 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

      0029 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2

      0030 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2

      0031 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0032 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0033 [W] 00001036 Software\Opera Software/Plugin Path 2

      0034 [W] 00001036 Software\Opera Software/Plugin Path 2

      0035 [I] 00000011 1

      =X====== M/11.7.700.202 2013-05-28+19-08-31.387 ========

       

      =O====== M/11.7.700.202 2013-05-28+19-30-08.045 ========

      0000 [I] 00000010 "C:\ProgramData\Adobe\AIH.12ec897f20cdf010dfe04ab63468ddd51905ca49\install_flash_player.e xe" -install -iv 8 -au 1

      0001 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/Version 2

      0002 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

      0003 [I] 00000011 1

      0004 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0005 [W] 00001037 SOFTWARE\MozillaPlugins\@adobe.com/FlashPlayer/ 2

      0006 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player Plugin/ 2

      0007 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2

      0008 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2

      0009 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0010 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0011 [W] 00001036 Software\Opera Software/Plugin Path 2

      0012 [W] 00001036 Software\Opera Software/Plugin Path 2

      0013 [I] 00000014 C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_7_700_202.dll

      0014 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_7_700_202_Plugin.exe

      0015 [I] 00000024 C:\Windows\SysWOW64\Macromed\Flash\plugin.vch

      0016 [I] 00000017 C:\Windows\SysWOW64\Macromed\Flash

      0017 [I] 00000022 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerPlugin_11_7_700_202.exe

      0018 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0019 [I] 00000021 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe

      0020 [I] 00000012

      =X====== M/11.7.700.202 2013-05-28+19-30-14.704 ========

       

       

       

       

      Thank you for any help you could provide.

       

      JF

        • 1. Re: Flash player detected as installed but not playing movies
          pwillener Level 8

          First, thank you for providing more information than anybody ever does!

           

          I do not have a ready answer for you (I never had any problems with Firefox updates, on a very similar system as yours), but allow me some additional questions, observations, and suggestions.

           

          Does the same thing happen on other browsers such as Internet Explorer?

           

          Is your graphics driver up to date?  (http://forums.adobe.com/thread/945765, but I don't think you need instructions.)

           

          The fact (your point 2) that you can obtain the Flash Player version indicates that Flash Player is basically working, although it does not display graphic content.  That "could" possibly get fixed with a graphics driver update.  (But not if Flash Player is working normally in another browser.)

           

          Why does that always happen when Firefox updates?  Do you uninstall the old version first, or just update in-place?  (Which should be the normal thing to do.)  Also, does it only happen with major updates (e.g. from 20.0 to 21.0), or also minor updates (20.0 to 20.0.1)?

           

          I see some warning lines in your FlashInstall.log; I am not sure if this means anything.  Can you once try a clean install according to http://forums.adobe.com/thread/928315 ?

           

          Hope we can get to the bottom of that!

           

          Message was edited by: Pat Willener

          • 2. Re: Flash player detected as installed but not playing movies
            slam_02 Level 1

            Hi Pat,

             

            thank you for your comments.

             

            About your questions:
            1. I have the latest graphic drivers.

            2. Works on other browsers. IE8 and chrome. Even though chrome uses pepper for its flash, at least we can rule out the graphic drivers like you mentionned.

            3. I use the firefox update-in-place. I never uninstalled firefox before yesterday. I have never installed firefox over an already installed firefox.

            4. As far as I know, it only happened on major updates. And not all of them. It also happened on some flash updates. I can't seem to find a pattern.

             

            I did the clean install from the link you posted. It has not worked.

             

            I found that installing flash after a clean unsinstall added a 32bit and a 64bit version of flash. Is that normal? Here's the installed file:

             

            C:\Windows\SysWOW64\Macromed\Flash>dir

            [ sliced for clarity ]

            05/30/2013  07:47 AM             3,264 FlashInstall.log

            05/30/2013  07:47 AM               856 flashplayer.xpt

            05/30/2013  07:47 AM         1,855,880 FlashPlayerPlugin_11_7_700_202.exe

            05/30/2013  07:47 AM           256,904 FlashPlayerUpdateService.exe

            05/30/2013  07:47 AM           813,448 FlashUtil32_11_7_700_202_Plugin.exe

            05/30/2013  07:47 AM                47 mms.cfg

            05/30/2013  07:47 AM        16,033,160 NPSWF32_11_7_700_202.dll

            05/30/2013  07:47 AM         1,561,187 plugin.vch

                           8 File(s)     20,524,746 bytes

                           2 Dir(s)  311,060,615,168 bytes free

             

            C:\Windows\System32\Macromed\Flash>dir

            [...]

            05/30/2013  07:47 AM             2,656 FlashInstall.log

            05/30/2013  07:47 AM           514,440 FlashUtil64_11_7_700_202_Plugin.exe

            05/30/2013  07:47 AM        22,025,096 NPSWF64_11_7_700_202.dll

            05/30/2013  07:47 AM           697,043 plugin.vch

                           4 File(s)     23,239,235 bytes

                           2 Dir(s)  311,060,615,168 bytes free

             

            Also, here's the new FlashInstall.log content:

            =O====== M/11.7.700.202 2013-05-30+11-47-08.337 ========

            0000 [W] 00001113 C:\Windows\SysWOW64\Macromed\Flash\\* 3

            0001 [I] 00000010 "C:\Users\jflavoie\AppData\Local\Adobe\AIH.54abe862adcf9fb0147fbf83f4329b5a776cffe7\insta ll_flash_player.exe" -install -iv 8 -au 1

            0002 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/Version 2

            0003 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

            0004 [I] 00000011 1

            0005 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0006 [W] 00001037 SOFTWARE\MozillaPlugins\@adobe.com/FlashPlayer/ 2

            0007 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player Plugin/ 2

            0008 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2

            0009 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2

            0010 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0011 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0012 [W] 00001036 Software\Opera Software/Plugin Path 2

            0013 [W] 00001036 Software\Opera Software/Plugin Path 2

            0014 [I] 00000014 C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_7_700_202.dll

            0015 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_7_700_202_Plugin.exe

            0016 [I] 00000024 C:\Windows\SysWOW64\Macromed\Flash\plugin.vch

            0017 [I] 00000017 C:\Windows\SysWOW64\Macromed\Flash

            0018 [I] 00000022 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerPlugin_11_7_700_202.exe

            0019 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0020 [I] 00000021 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe

            0021 [I] 00000012

            =X====== M/11.7.700.202 2013-05-30+11-47-14.056 ========

             

             

            Thank you for your support.
            JF

            • 3. Re: Flash player detected as installed but not playing movies
              pwillener Level 8

              slam_02 wrote:

               

              I found that installing flash after a clean unsinstall added a 32bit and a 64bit version of flash. Is that normal?

              Yes, that is normal, so that it can run under 32-bit and 64-bit browsers.

               

              I will look at your install log later; probably not before tomorrow.