3 Replies Latest reply on May 30, 2013 2:15 AM by 99jon

    Error You need to have Internet Explorer 4.0 or greater to install Photoshop Elements

    Johnbenjones

      I get the above error when I try to install Photoshop Elements. I have EI 10 installed but use firefox as my defalut browser, any Ideas?