This content has been marked as final. Show 3 replies
in your code ,this should use a MC ,the mc has what u want !!
I just tested this and it worked fine for me – when I did correctly. As soon as I actually looked closely at your code I found the mistake. Remember flash does what you tell it, not what you want!
In your attachMovie you are giving the new instances a _name which is stored in a variable called "ball"+i. But since that is where you are attaching them they aren't getting any name because no such variable could exist. So that is actually the name you have given them. So I suppose "technically" it is also working thin this format.
My guess is that you want to just name them like this:
Also just a pet peeve of mine the function you are caling iisn't really a movebal function, that is handled by the onEnterFrame. Give it a better name, I think attachBal would be much better.
Thanks Rothrock ! [This] way it worked! ;)
I can sleep again :)