1 Reply Latest reply on Jun 3, 2013 4:55 PM by Genevieve Laroche

    Required upgrade

    whydoineedthis1

      When openeing FormsCentral, a pop up states that the software must be upgraded and when clicking on the pop up, it takes me to the page to buy a subscription. I have Adobe Pro XI and was wondering why this was happening.