3 Replies Latest reply on Jun 5, 2013 3:15 AM by Peter Spier

    Default font for new text box

    XYGamma

      When I draw a new text box, it opens with an odd font. How do I set the default font for a new text box?

       

      On a related topic, when I draw a new graphics box prior to placing a new picture, is there a way to have it start with a default text wrap value?

        • 1. Re: Default font for new text box
          Steve Werner Adobe Community Professional & MVP

          To set the default font for all documents, quit out of all documents, but keep InDesign open.

           

          Click on the Text tool, and select the font you want to be default. Open the Text Wrap panel and select the default text wrap.

           

          To set it for a particular document, select the font  or the default text wrap when nothing is selected.

          • 2. Re: Default font for new text box
            Willi Adelberger Most Valuable Participant

            I would recommend to set up paragaph styles according to your needs.

            Select this style

            When you do it without a text tool selected it will be the default style for this document. If you do it when no document open is, it will be the default style for any new document which will be created on that computer.

             

            You can set up your styles in any document, close the document and import the styles in the (paragraph) style panel menu and set up your default selection. This is also valid for all styles (paragraph, character, table, cell and object styles and watches).

             

            Of course, you can simply choose you favorite font without any style when no document is open, but I would not recommend that.

            • 3. Re: Default font for new text box
              Peter Spier Most Valuable Participant (Moderator)

              Steve Werner wrote:

              Open the Text Wrap panel and select the default text wrap.

               

              Big Warning here: If you set a default text wrap this way, it applies to ALL objects, not just images, so your new text frames will also have text wrap applied to them. This is generally NOT what you want.

               

              A better option would be to create an object style that includes the text wrap and apply it to your image frames. Unfortunately there is an oddity with ID and frames drawn with the Frame tools (the ones with the X in them). No matter what you specify for an object style, as soon as the frame is drawn it switches to the [None] object style and loses any stroke, fill or text wrap that you might have chosen. This is apparently hard-coded into ID and cannot be changed by the user except by following the procedure below.

               

              You can work around it in two ways: For frames that you draw and then put images into, use the Shape tools instead (the ones without the X). They respect object styles or locally set defaults for fill, stroke and text wrap, and there is no functional difference between shapes and frames other than the default content type (no content for shapes). They can hold graphical content or text content, or no content just by your choice of what you do with them. For placing images without an existing frame, create a new Object Style named "Place Gun Frame" (without the quotes) and set your parameters in that style. All placed images that have no pre-existing frame will automatically use this style instead of [None] regardless of what other settings you might have chosen.

               

              Or you can just apply your text wrap object style to each frame as you go, but that's not much better than applying the wrap over and over.