2 Replies Latest reply on Oct 15, 2007 12:08 PM by Newsgroup_User

    xml file - how to ignore space

    Nick201 Level 1
      I am creating xml file.But when I create as .xml file it is showing me lots of space between element. How can i remove the space. Let say if i have query it will count as a space.

      <Name>
      space
      i want to remove this space
      <Address>sdfsf</Address>


      </Name>

      thanx
        • 1. Re: xml file - how to ignore space
          Level 7
          Showing a small snippet of code would probably help with this question.
          Assuming one is using CFML to build the XML data, there are quite a
          few whitespace management tools built into ColdFusion these days. Some
          you may want to investigate are:

          <cfprocessingdirective suppresswhitespace="yes">

          <cfsetting enablecfoutputonly="yes">

          <cfsilent>

          And the CF administration settings concerning whitespace.

          As well as just building your code to minimize white space.

          They all have slightly different caveats and use cases.


          • 2. Re: xml file - how to ignore space
            ToBeNamedLater Level 1
            Some combination of
            <cfsetting enableCFoutputOnly = "yes|no"
            or
            <cfprocessingdirective suppressWhiteSpace = "yes|no"

            should get you there