9 Replies Latest reply: Jun 13, 2013 10:31 AM by jiggy1965 RSS

    typing of accented characters changes font

    jiggy1965 Community Member

      I'm using Illustrator CS6 on a Mountain Lion Mac. Got a weird problem with one of my fonts. I'm used to type accented characters like é by typing option-e plus e. Which works so far. On one of my fonts however, EuroComic, when I want to type the é character and start with option-e, it already changes the font to Myriad Pro. Typing the e after that makes it é, but in Myriad Pro, not EuroComic. It has always worked before when I was still using Snow Leopard. And it's not a font problem I think, cause in Indesign that same way of using option-e plus e works. The é is at the correct spot in EuroComic cause when I select all text and change it to EuroComic (after having typed that é), not only does all text turn into EuroComic again, but also that now Myriad Pro é turns back to EuroComic é. What could it be that could make illustrator turn the font to Myriad Pro after typing option-e on that parcitular font? With other fonts like Arial etc. I don't have that problem.

        • 1. Re: typing of accented characters changes font
          Steve Fairbairn Community Member

          Look at Type > Glyphs to see whether é is in your font.

          Type é and watch the Glyphs panel while you have é selected.

          What shows up?

           

          If there is something wrong with the font you will need softwarwe such as FontLab Studio to correct the arrangement of the font table.

          • 2. Re: typing of accented characters changes font
            jiggy1965 Community Member

            Yes it is and it is in the correct spot. It always worked with the entire CS3. And it does work in Indesign/Photoshop CS6 and Pages. Only in Illustrator CS6 it acts funny. So I wanne type an é with option+e plus e. But already whey I press option+3 it turns from EuroComic to MyriadPro. After that I can select the text box and turn the entire text into EuroComic and the EuroComic é is back. So it's in the correct spot and present in the font.

            • 3. Re: typing of accented characters changes font
              [Jongware] MVP

              Illustrator is too smart.

               

              With other fonts like Arial etc. I don't have that problem.

               

              Arial contains a separate acute character, and I bet your EuroComic does not. Illustrator tries to 'protect the stupid user' by automatically changing the font because it thinks you are trying to insert a character that is unavailable in the current font. (You are, but only for a short while.)

               

              Go to Preferences, Type, and un-check "Enable Missing Glyph Protection" to fix this.

              • 4. Re: typing of accented characters changes font
                jiggy1965 Community Member

                Wow, that worked!! But why is it thinking the é isn't available in EuroComic while it is? And at the same location as every é in other fonts? Or is it first looking at that special separate é character location like in Arial and when it doesn't find it there uses the more general location of é like where it is located for most fonts? (when 'enable missing glyph protection' is deactivated that is)

                • 5. Re: typing of accented characters changes font
                  [Jongware] MVP

                  Colaflash wrote:

                  why is it thinking the é isn't available in EuroComic while it is?

                   

                  Exactly what I said: "it thinks you are trying to insert a character that is unavailable in the current font. (You are, but only for a short while.)"

                   

                  It has nothing to do with the 'location' of "é" -- this is the same as in every font. It's due to the way you can type in accented characters in Mac OS X.

                   

                  You type an acute character; Illustrator receives it and switches immediately to the fallback font (Myriad Pro). Next you type an 'e'. Your friendly Mac OS, watching over your shoulder, removes the acute accent and replaces it with an é. Illustrator doesn't notice this and leaves the font changed to Myriad.

                  • 6. Re: typing of accented characters changes font
                    jiggy1965 Community Member

                    ok, but if it has nothing to do with location as it is the same in every font, why is illustrator thinking the é is unavailable in EuroComic while it is thinkg it is available in é? Why would it think EuroComic doesn't have a separate acute character?

                    • 7. Re: typing of accented characters changes font
                      [Jongware] MVP

                      Please read again what I say above about how an accented character is entered in OS X.

                       

                      Illustrator doesn't think the é is unavailable, it thinks the single acute accent ´ is unavailable. And it is correct in that, for EuroComic, so Illy changes the font to Myriad.

                      • 8. Re: typing of accented characters changes font
                        Sigurdur Armannsson Community Member

                        I have seen this too in Fonts that are made by non-professionals.

                        One way I found to bypass this is to type the text in text editor and paste it then into Illustrator.

                        • 9. Re: typing of accented characters changes font
                          jiggy1965 Community Member

                          ok, sorry, I misunderstood So can you tell me where that single acute accent ' supposed to be located in a more normal font like Arial? Curious if indeed at the same location that accent is missing in EuroComic

                           

                          Edit: I'm guessing U+0027? I've compared that with EuroComic and while it has a ' character, the glyphs panel says it's located at U+2019. Though it's also between & and (. In EuroComic it skips from U+0026 to U+0028. With U+2019 in between. Still the same accent character but under a different U code. So I'm guessing the mac is expecting it to be at U+0027, doesn't find it (cause somehow it is set in the font as 2019) and causes those problems?