7 Replies Latest reply on Jun 20, 2013 1:15 AM by sonicdee654

    Can't install plugins from exchange panel in PS CC!

    sonicdee654 Level 1

      I tried to install some plugins from the exchange panel inside PS cc,

      it downloads the addin, but when it starts the extension manager,

      there is an error -1 after some time it tries to install them...!

        • 1. Re: Can't install plugins from exchange panel in PS CC!
          steven I ross

          Had a similiar problem- the exchange/extension combo attempted to install the "Urban Landscape-indii pluin". It created a "Contents" sub folder in plug-ins, and deleted ALL of my plug-ins!

          Mac Photoshop CC.

          • 2. Re: Can't install plugins from exchange panel in PS CC!
            shuo_yang Level 2

            What is your OS?

             

            If windows, remove opm.db from C:\Users\yourname\AppData\Local\Adobe\OOBE directory and reinstall it again.

             

            If the issue is not solved, please update your "Adobe Application Manager" or "Creative Cloud Client" to the latest

            • 3. Re: Can't install plugins from exchange panel in PS CC!
              sonicdee654 Level 1

              it's a macbook 10.7.5

               

              there are no updates at all inside the CCC updater, i restarted it, too.

              ExtensionManager Version is 7.0.0.347

              inside Adobe Exchange Panel  -> Update = No Updates available

               

              ^^ how to update the CCC ?

              • 4. Re: Can't install plugins from exchange panel in PS CC!
                shuo_yang Level 2

                CCC is the latest.

                 

                What about delete opm.db in /Users/yourname/Library/Application Support/Adobe/OOBE and reinstall this extension?

                 

                If doesn't work. Try to reinstall CCC.

                • 5. Re: Can't install plugins from exchange panel in PS CC!
                  sonicdee654 Level 1

                  deleted opm.db -> no success

                  unstalled the Cloud Downloader, loaded it again from the web -> no success:

                  everything is on date, no updates available...

                  And installing something doesn't work:

                   

                  • Installing Adobe Paper Textures Pro from inside Exchange Panel inside PS cc
                  • its downloading
                  • it says installing - for a looong time
                  • it asks to open Extension Manager CC to install -> Yes
                  • Extension Manager starts and says installing - for a looong time
                  • Extension Manager brings error: Error occured. Error code is -1
                  • 6. Re: Can't install plugins from exchange panel in PS CC!
                    shuo_yang Level 2

                    If you can send the log file to me by following step, I could get more detail about this issue.

                     

                    1. Create a file named "ExManCoreLibLog.Yes" in the folder

                    /Users/yourname/Library/Application Support/Adobe/Extension Manager CC/Log

                     

                    2. Install any extension to let Extension Manager to bring error

                     

                    3. The log file ExManCoreLibrary.log is in the folder

                    /Users/yourname/Library/Application Support/Adobe/Extension Manager CC/Log

                    • 7. Re: Can't install plugins from exchange panel in PS CC!
                      sonicdee654 Level 1

                      I've got a clue, but don't know if it's my or your problem

                       

                      Here's the log - I found out that it has to do with system proxy, maybe you don't use it, maybe I need to do something on the proxy side...

                      ^^ so - solved for me - I use no proxy at all

                       

                      Heres the log:

                       

                      [Error] Thu Jun 20 08:35:21.656 2013 (/Volumes/Develop/jenkins_slave/workspace/ExMan_7.0_RIBS_Mac/ExManCoreLibrary/Mac/../Sour ce/Util/ExtensionUnpackager.cpp, 212) -Failed to decompress zxp file: 2304

                      [Warning] Thu Jun 20 08:35:28.304 2013 (/Volumes/Develop/jenkins_slave/workspace/ExMan_7.0_RIBS_Mac/ExManCoreLibrary/Mac/../Sour ce/Util/SignatureValidator.cpp, 155) -CSignatureValidator::verifySignature: timestamp has an in-range date and is valid!

                      [Error] Thu Jun 20 08:37:21.699 2013 (/Volumes/Develop/jenkins_slave/workspace/ExMan_7.0_RIBS_Mac/ExManCoreLibrary/Mac/../Sour ce/ExtensionBase.cpp, 219) -CExtensionBase::validateExtension: validateAgoraLicense() failed for extension Flypaper Select, status = -1!

                      [Error] Thu Jun 20 08:37:21.699 2013 (/Volumes/Develop/jenkins_slave/workspace/ExMan_7.0_RIBS_Mac/ExManCoreLibrary/Mac/../Sour ce/ExtensionBase.cpp, 598) -CExtensionBase::install: validateExtension() failed for zxp /private/var/folders/hz/b_w0bfcd7lvcgr8842lf7zph0000gn/T/TemporaryItems/FlashTmp1/com-fly papertextures-FlySelect.zxp, status = -1!