1 Reply Latest reply on Jun 26, 2013 5:34 PM by elainecc

    Ajax problem

    jacouille22

      Hi

      I have a page index, index.html,

      In this page a link (in a menu) to load via an ajax call an Edge Animate animation in an overlay box.

      When I click on the link for the first time the overlay opens and the Edge Animation plays inside the overlay.

      When the overlay is closed (by clicking the close overlay button), if I click again on the link, the overlay opens byt the Edge Animation is not playing.

       

      I would appreciate if somebody could help me to fix this issue.

       

      Thank you in advance.

       

      Jean.

       

      Here is the code of my Ajax called page.

       

       

      <!--Adobe Edge Runtime-->

      <script type="text/javascript">

      yepnope({

                load: ["page_a_edgePreload.js"],

        complete: function (url, result, key) {

                  AdobeEdge.bootstrapCallback(function(compId) {

                  });

        }

      });

      </script>

      <style>

              .edgeLoad-PAGE_A { visibility:hidden; }

      </style>

        

      <!--Adobe Edge Runtime End-->

      <style>

      #Stage {

                width: 1010px;

                height: 209px;

                margin:0; padding:0;

       

                }

      </style>

       

      <div id="Stage" class="PAGE_A">

        • 1. Re: Ajax problem
          elainecc Adobe Employee

          Hi, jacouille22-

           

          Without looking at your project, it's hard to say.  If I were to hazard a guess, I'd say that the browser is probably caching the page and not reloading the animation.  This means that you might need to explicitly call play again after you reload.  Perhaps you can post your file?

           

          -Elaine