0 Replies Latest reply on Oct 18, 2007 10:21 PM by dnii

    Receive AS error that doesn't occur in debug mode

    dnii Level 1
      I have a bit a tricky situation at hand where I get an ActionScript error when I run my Flex application but when I run it in debug mode the error no longer seems to occur...

      The error message reads:

      quote:

      TypeError: Error #1010: A term is undefined and has no properties.
      at mx.controls::AdvancedDataGrid/findHeaderRenderer()[C:\Work\flex\dmv_automation\projects\d atavisualisation\src\mx\controls\AdvancedDataGrid.as:1304] at mx.controls::AdvancedDataGrid/mouseEventToItemRenderer()[C:\Work\flex\dmv_automation\proj ects\datavisualisation\src\mx\controls\AdvancedDataGrid.as:1270] at mx.controls.listClasses::AdvancedListBase/mouseMoveHandler()[C:\Work\flex\dmv_automation\ projects\datavisualisation\src\mx\controls\listClasses\AdvancedListBase.as:8070]


      The error happens intermittently when I move the mouse cursor across the column divider lines in an ADG (AdvancedDataGrid) with three levels deep grouped headers.

      It seems to be some kind of a timing issue perhaps because it is only intermittent?

      I have not yet been able to distill it down to a sample that causes this problem.

      Any suggestions on how to tackle this problem?