4 Replies Latest reply on Jun 24, 2013 8:22 PM by uhanepono

    doc. looses link to original smart object doc.

    uhanepono Level 1

      Hi I am having trouble with my PScs6 wherein the layered doc I am working on looses it's link to the surce file within the smart object "container" layers refering to it. I opened up a saved version from timemachine and the same thing happened. At the same time ALL the masks all went nuts and presented with lined artifacts instead of white (in the case of adjustment clipped layers to the smart object. The original file was not moved to a new location or deleted. I closed PS6 and reopened to find the problem did not go away. It started when I used the rotate tool to do some fine work on the smart object's mask with brush and wand. I was using the fill command to fill the wanded areas in the mask. I believe it was a problem with the rotate tool because it became more and more jerky and resizing over 100% caused the image within the smart object to dissappear on all layers using that source image in the doc. PS6 has been buggy and crashing more frequently recently in general, especially after using plugins that have worked flawlessly for years. 

      I run a macbook pro with snow leopard. 10.6.8

      Let me know what info you need

       

      Here are screen shots

       

      this one show the smart object now emptied of it's source image after using the rotate (R) tool for a while and zooming in over 100%..

      Screen shot 2013-06-19 at 12.10.05 PM.jpg

       

      this one shows the mask artifacts (on the topmost "wash" layer mask) that also developed after using the rotate (R) tool for a while and zooming in over 100%.

      Screen shot 2013-06-19 at 12.10.00 PM.jpg

        • 1. Re: doc. looses link to original smart object doc.
          JJMack Most Valuable Participant

          Smart Object Layers embedded object are copies of the original file. No link is in there. Smart object layers are independant and have no association with the original file. They are self contained.

          • 2. Re: doc. looses link to original smart object doc.
            Level 7

            Smart Objects don't remember the original file at all - they are embedded in the parent document, not links.

             

            Have you installed all the Photoshop CS6 updates?

             

            Have you disabled all third party plugins?

             

            What about font managers?

             

            What you're describing sounds like something is corrupting the file or memory while you work with smart objects.

            • 3. Re: doc. looses link to original smart object doc.
              uhanepono Level 1

              Thanks for the speedy response. The problem, after restarting the apps for the second time, seems to have corrected itself. I want to add that this problem was with more than the open doc I opened a saved time machine copy and found the same problem there. Which is why I started assuming the parent file was the source file.  So a memory issue? I am wondering if my graphics tablet might be a cultrit. It is VERY (pre tilt even) old and more and more feeble in these last few weeks. I just removed a color mixer pallet from anastasia that I recently got as a trial. Sometimes when I use the magic picker fro mthe same company it will cause the tablet to not change tools and color fore/background. But I had assumed it was the old tablet. I will experiment.

              •••well here is a screen shot of 3rd party periferals I have installed.

               

              Screen shot 2013-06-19 at 2.47.33 PM.jpg

               

              Screen shot 2013-06-19 at 2.44.32 PM.jpg

               

               

               

               

               

               

               

              Chris Cox wrote:

               

              Smart Objects don't remember the original file at all - they are embedded in the parent document, not links.

               

              Have you installed all the Photoshop CS6 updates?

               

              Have you disabled all third party plugins?

               

              What about font managers?

               

              What you're describing sounds like something is corrupting the file or memory while you work with smart objects.

              • 4. Re: doc. looses link to original smart object doc.
                uhanepono Level 1

                HI Chris. PS6 is back to acting all squirrely. Today it opens and then closes at once without delay and indicates then that it crashed. Bridge seems to have stabilized after purging the cashe and all the icons etc. I had a repairt disk problem on snow leopard and after I repaired the disk and then repaired preferences in disk utility is when the problem began.

                 

                Ok I reinstalled the app from a DMG and the same thing happened. I then used the cleaner tool to delete the app again and will now reinstall from the physical disk....

                 

                after the above steps the app stays open. It must have been a file adobe needs that got swept away in the all the fuss.

                 

                reinstalling all presets and extentions rather than restore from time machine just incase. all well so far. thanks for reading this far. I will repost if there are any further kerfuffles. Your rock Chris!

                 

                Ok NOW CRASHING again after updates!