0 Replies Latest reply on Jun 19, 2013 10:17 PM by pherako

    FP11 on PartedMagic x64 does not load properly

    pherako

      Had a need to run flash player on a drive recovery tool. Downloaded the latest x86_64 tar.gz, followed instructions and got this gem:

      LoadPlugin: failed to initialize shared library /root/.mozilla/plugins/libflashplayer.so [/root/.mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS64]

       

      uname -a
      Linux partedmagic 3.8.10-pmagic64 #1 SMP PREEMPT Mon Apr 29 20:33:04 CDT 2013 x86_64 Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz GenuineIntel GNU/Linux

       

      ldd /usr/lib64/kde4/kcm_adobe_flash_player.so
          not a dynamic executable

       

      ldd ~/.mozilla/plugins/libflashplayer.so
          not a dynamic executable

       

      I'm not sure where to go from here. It's not critical, and I'm sure it'll run in 32-bit mode (it has in the past). Anyone have any suggestions?