10 Replies Latest reply: Jul 29, 2013 3:00 PM by Mike Gondek2 RSS

    Font Problems

    cgjondla

      I have a Mac on 10.7 running cs6 Illustrator. I have been able to load fonts into Font Book but when opening the document I get the error below. This is only happening on one mac out of 6 that use this font. I have tried fixing permissions and clearing the font cash. Any other suggtions i can try to resolve this issue?

       

      Untitled.png

        • 1. Re: Font Problems
          [scott] Community Member

          Reinstall the font from original media. It's possible the font file itself has become corrupt.

          • 2. Re: Font Problems
            cgjondla Community Member

            Tried reinstalling but still ran into the same issue.

            • 3. Re: Font Problems
              OldBob1957 Community Member

              Stupid question: Are you certain that all six stations are running the exact same version of that font?

               

              I've seen this occasionally when a file was created with an Open Type Font, and the receiving machine had the "same" font, but as True Type (or Type 1).

               

              --OB

              • 4. Re: Font Problems
                cgjondla Community Member

                They are all working from the same source files. I didnt see anything about true type.

                • 5. Re: Font Problems
                  cgjondla Community Member

                  Any other suggetions I can look into?

                  • 6. Re: Font Problems
                    Monika Gause CommunityMVP

                    Is there only one Helvetica present on that machine?

                    • 7. Re: Font Problems
                      Tigerswallowtail

                      I have had a series of font issues in Illustrator only since upgrading from CS5 to CS6. Issues are further complicated by OS. In Win 7, several fonts that are installed are not visible in Illustrator CS6. In Win 8, even more fonts are not visible in Illustrator CS6. The same issues occur on both a clean install on a new computer and on upgrade installation on an existing computer. I have tried everything I could think of: clearing cache, unintstalling/reinstalling fonts and software, clearing font cache. Nothing works.

                       

                      I had to reinstall my original CS5 on a Win 7 computer just so I could update a client's logo. I have been searching for a fix to this problem for so many months now that it seems fruitless. I have just resorted to using CS5 for old/existing files becasue of the endless hours I have wasted trying to troubleshoot this issue. This whole thing sucks becasue Illustrator CS6 has so many great new features but the way it handles fonts is so BAD that I can't even warrant even setting up important client files like logos in it.

                       

                      There is one thing I have been able to identify, however: all ITC fonts that are really old (10-20 years old) won't display. I can't find infor anywhere on why this is. Unfortunately, however, this issue occurs with other fonts -- different manufacturers and ages -- as well. All fonts are OT.

                       

                      Note also that all the fonts in question are all accessible and usable in all other CS6 programs like InDesign, Photoshop, etc. They just don't show up in Illustrator.

                      • 8. Re: Font Problems
                        Mike Gondek2 CommunityMVP

                        The dash between the font name suggests this is the old T1 version. Try not use use that version of the font, it conflicts with some popular fonts, and the metrics are not as good.  You may possibly have some minor reflow going to Helvetica Neu Regular that is in your fontbook, but you will have less problems in the end.

                         

                        Screen Shot 2013-07-29 at 2.08.23 PM.png

                        • 9. Re: Font Problems
                          cgjondla Community Member

                          How do I cange the default from using the font?

                          • 10. Re: Font Problems
                            Mike Gondek2 CommunityMVP

                            The default font used by Illustrator when you click the type tool comes from the profile you choose when making a new document. All the document profiles are actually set to Myriad, unless an advanced user in your group edited the document profiles.

                             

                            What I was suggesting for you to do is type >> find font >> (top)HelveticeNeue-Roman >> (Middle)Replace with from form  System>> (Bottom)Helvetica Neu) >> Change All  and save the document. Then save, and another machine should open with no missing font.

                             

                            Your options would look similar to this (except with the correct font names as above).

                             

                            Screen Shot 2013-07-29 at 4.58.10 PM.png