0 Replies Latest reply: Jun 25, 2013 1:52 AM by theFlexer RSS

    Channel Security Error problem

    theFlexer

      Hello everyone

       

      I just bought and installed flash builder 4.7 and since i've done that my apps don't launch any more...

      I  got a "Channel.Security.Error" message at first attempt to get data from my php services...

       

      I tried to access data that are on my computer (http://localhost/getDatas.php?tk=123456&pf=6650ff04) and I also tried with external services and got the same result.

       

      The complete message is :

      "

      [RPC Fault faultString="Security error accessing url" faultCode="Channel.Security.Error" faultDetail="Destination: DefaultHTTP"]

          at mx.rpc::AbstractInvoker/http://www.adobe.com/2006/flex/mx/internal::faultHandler()[E:\dev\4.y\frameworks\projects\rpc\src\mx\rpc\AbstractInvoker.as:345]

          at mx.rpc::Responder/fault()[E:\dev\4.y\frameworks\projects\rpc\src\mx\rpc\Responder.as:68]

          at mx.rpc::AsyncRequest/fault()[E:\dev\4.y\frameworks\projects\rpc\src\mx\rpc\AsyncRequest.a s:113]

          at DirectHTTPMessageResponder/securityErrorHandler()[E:\dev\4.y\frameworks\projects\rpc\src\ mx\messaging\channels\DirectHTTPChannel.as:437]

          at flash.events::EventDispatcher/dispatchEventFunction()

          at flash.events::EventDispatcher/dispatchEvent()

          at flash.net::URLLoader/redirectEvent()

      "

       

      In the directory were is my php service (getDatas.php) is a crossdomain.xml file containing  :

      "

      <?xml version="1.0"?>

      <!DOCTYPE cross-domain-policy SYSTEM "/xml/dtds/cross-domain-policy.dtd">

      <cross-domain-policy>

          <site-control permitted-cross-domain-policies="all" />

          <allow-access-from domain="*" to-ports="*" />

          <allow-http-request-headers-from domain="*" headers="*" secure="false" />

      </cross-domain-policy>

      "

       

      Everything was working perfectly before i decided to upgrade to 4.7, when i was developping with flashbuilder 4.6.

       

      I try to start a new project with only an httpservice object which is triggered in the creationcomplete event but i still got the same result.

       

      I'm now completely stuck and any help would be appreciate...

       

      Thanks