0 Replies Latest reply on Jun 26, 2013 1:07 PM by waltepa

    Sound Solution in Animate -- almost

    waltepa Level 1

      Ok, I've been searching the boards and W3Schools for an answer to my problems with adding sound to an edge animate file in Muse


      After MUCH trial and error, I finally got it working with the LEAST bit of code.


      What's been missing is how to tell a total non code person how to do it.

      I've got it working (finally) but I can't get the controller to work.  This is what I did.


      1. open htm file in Dreamweaver

      2. go to html page and insert the code AFTER


      <body style="margin: 0; padding: 0; height: 100%;">

          <div id="Stage" class="EDGE-#########">


      and BEFORE





      code to insert:


      <audio id="filename" preload="auto">

                  <source src="folder/filename.ogg" type="audio/ogg">

                  <source src="folder/filename.mp3" type="audio/mpeg">




      in my case it looks like this:


      <audio id="myName" preload="auto">

                  <source src="media/myName.ogg" type="audio/ogg">

                  <source src="media/myName.mp3" type="audio/mpeg">




      NOTE:  I tried adding audio controls to the code, but all that came up was a controller that didn't pause, stop, mute or rewind.


      3. save the html file in DW


      4. Reopen the file in EdgeAnimate


      When you open the file, the sound will be listed in the library.

      Highlight the file in the list

      I set it to always on / visible to make it appear on the timeline

      Then go to the point on the timeline you want it to play and click the playback button where you want it to start.


      5.  publish the file.


      6.  then you MUST copy the folder & files referenced in the code and past it in the same folder as the published oam file.


      in my case i copied the "media" folder & contents.


      7.  place the oam file on your web page and publish the page.


      VOILA! your animation has sound.




      here is the page:




      If I open in in GC, it crashes since the upgrade.  Don't know if that's my own system or for everyone.  But it works great in FF, IE and even Safari!  Except of course for the controller.  Haven't tested Opera.


      Since this is the home page I really do need to get a controller on there  soon!.


      Anyone?  Please, please, please!?


      Thanks much!