1 Reply Latest reply on Jun 26, 2013 5:01 PM by Jeff A Wright

    Why cant I go on another site to do something and tells me I need newer version

    fedupofthis

      i have downloaded flash plater and when i went on to another site it says i need a newer version ,,,,,,HELP