4 Replies Latest reply on Jun 28, 2013 12:11 PM by Ian Kelleigh

    Severe Puppet Warp bug

    Ian Kelleigh

      I have been having this issue with certain uses of Puppet Warp and I'm not sure if it's how I'm using, the settings I have for the warp or my computer.

       

      It happens on two different MacBook Pros with 8GB of RAM, on Mac OS X 10.8.4

       

      I will spend about 40 minutes warping a photo converted to a Smart Object so that it looks like it's wrapping around a blanket like so:

       

      Untitled-1.jpg

       

      This usually works just fine. I can save the file, and edit the photo more as time goes on and nothing is odd... until I save and come back to the file later.

       

      When I open the file and try to edit the photo in the Smart Object, reduce the size of the entire image, or even just double-click on the Puppet Warp filter on the layer panel, it does this:

       

      Untitled-2.jpg

       

      The pins are way off the board, the image looks like it's split into different parts and the only way to get it back is to Undo any changes. The settings for the Puppet Warp are: Normal, Normal, 2px

      The image is 7"x5" at 240dpi.

       

      This doesn't happen with all of my Puppet Warped images, but this one shows this behavior every single time. At one point I went in and recreated the Smart Object and Puppet Warp and it did the exact same thing after I was finished. This happens in both CS6 and the new CC versions of Photoshop.

       

      Has anyone ever seen anything like this and if so, is there a solution?

       

      Thanks in advance!

      -Ian