4 Replies Latest reply on Jul 29, 2013 1:46 AM by robboerman

    Can't control the audio elem after loading the Edge libs.

    YOSHIOKA Ume Level 3

      I can't control the audio elem after loading the Edge libs.

      Here is a simple js & HTML.

      <script>
      function init(){
        var bgmControl = document.getElementById("bgm");
        bgmControl.play();
        bgmControl.currentTime = 2;
      }
      </script>
      
      <body onLoad="init()">
        <audio id="bgm" src="sounds/sound.mp3" controls>
      </body> 
      

      I open this html at Browser(ex:Chrome). I can see the Audio elem like that.

      img01.png

      BGM is played from 2000 ms. can seek. that's fine

       

      Next. I open the same html by Edge Animate, and publish(I do not add anything), open, like that.

      img02.png

      BGM is played from 0 ms.can't seek.

      I can't control audio elem any more

       

      -before loading the Edge libs:every control is O.K.

      audio.play()

      audio.currentTime

      audio events(ex:seeking, seekd etc..)

       

      -after loading the Edge libs:some of control is N.G.

      audio.play() - O.K.

      audio.currentTime -N.G.

      audio events(ex:seeking, seekd etc..) -N.G.

       

      I guess, EdgeLib override/stop the default event on audio element.

      so, I can't control the every aoudio pos from Edge Animate(even if I use any library that uses the Audio element).

      just play sound, but can't control any more.

       

      Do you know how to resolve?

       

      Ume.