3 Replies Latest reply on Jul 2, 2013 11:50 AM by Jeff Arola

    Photoshop 7 - batch processing is no longer doing save as

    hockeysnapper

      I have had Photoshop 7 for many years.  I have been using several resizing and sharpening batch processes which have saved a resultant file at the end with a different name.  In the Batch process an original folder was selected and a destination folder and the file name changed with a different custom prefix.  I have been using these batch processes with no problems for years.  Without warning I have noticed that all of these batches are no longer working and the end result is one file in the destination folder, ie it must me overwriting.  I have tried to recreate the basic batch process again  and have resorted to using both 'save; and 'save as' at the end of the process in different test batch processes and the same result happens pretty much each time, the one file after the original folder had 5 images.  I have noticed that 'Save as' is not showing up in the actions of the batch process (only shows as 'Save' irrespective if you selected 'save' or 'save as'.  It is like Photoshop is refusing to accept 'save as' with a new file as a valid action.  I have also tried to check the override 'save as' box etc.  If you edit normally in Photoshop and 'save as' for that image, there are no problems

       

      Going nuts as I am a team photographer for a team playing in a national competition and therefore have a large volume of images to edit/resize

       

      cheers

       

      Hockeysnapper

        • 1. Re: Photoshop 7 - batch processing is no longer doing save as
          Mylenium Most Valuable Participant

          Without system info nobody can help you. these could be mundane permissions/ user privilege issues that prevent creation of new files/ folders out of the current user's security context just as this could be performance issues with your drives getting full or external tools interferring. whatever. We simply can't know.

           

          Mylenium

          • 2. Re: Photoshop 7 - batch processing is no longer doing save as
            hockeysnapper Level 1

            Windows XP previously, Windows 7 now (has been for about a year). 

            Computer is according to 'device and printers', ACPI x86-based PC, with Intel Core i5-3450 CPU@3.10Ghz, and Xeon processor E3-1200 v2/3rd Gen Core - was all put together last year.

            Drives are nowhere near full.

             

            Only recent update has been Java on the weekend, coinciding with when I first noticed the issue.

             

            I have deleted Photoshop 7 off the computer using Windows 7's delete program function as there is no uninstall.exe file in the PS7 folder.  I deleted it out of Startup and off the Desktop.  I also deleted the remaining plugin folder containing Noise Ninja anti-noise software.

            I reinstalled the PS7 software again and in PS7 I expected the batch processes now to only contain the default batch processes, but all of my created ones are there in the list - this says they are not deleted in the uninstalll process.  Where are these stored on your computer so I can delete these perhaps?  However I am unconvinced that will actually achieve anything (see * below).    I deleted a few of these using the trashbin off the Actions palette.

            I created the numerous variations of the batch processes again, with 'save as overrides' box checked/unchecked and still no joy.  What I have noticed it does not matter whether you used 'save as' as one of your actions it has replaced it with 'save' every time (*).  How does/can that happen?  All the other 'save' actions for any of the other batch processes all show as 'save' now.    There is of course no option to change the 'save' in the actions to 'save as', eg right click mouse or something.

             

            I haven't found anything related in Google searches.

            • 3. Re: Photoshop 7 - batch processing is no longer doing save as
              Jeff Arola Adobe Community Professional

              Could you post a screenshot of one of the actions and a screenshot of the settings your using in the batch dialog?

              (with all the steps in the action open)