8 Replies Latest reply on Jul 4, 2013 8:13 AM by Slehmann1111

    Movie symbol only plays first frame

    Slehmann1111

      I have a movie symbol of a fire with about 20 frames, however whenever I add it to the timeline only the the first frame plays.

       

      Inside movie symbol:

      Untitled.jpg

      Timeline proof of not animating:

      Untitled.jpg

      Untitled.jpg

        • 1. Re: Movie symbol only plays first frame
          robdillon Most Valuable Participant

          If I'm looking at this correctly, you have an 18 frame movieClip of a flame. In the main timeline you have 2 layers "Fire" and "layer 1". In "Fire" you have 18 frames of a blurred flame. and in "layer 1" you have something else, but only in 1 frame of the timeline.

           

          Is the movieClip containing the clear version of the flame in the layer "layer 1"? If that's the case, then you won't see that movieClip except at the very start of the movie. It only occupies 1 frame of the main timeline. Like anything else in the timeline, it will need to be extended in order to be seen? Further, you have that layer's visibility turned off, so you won't see the contents of that layer at all.

          • 2. Re: Movie symbol only plays first frame
            Slehmann1111 Level 1

            No it is not, here is it with that layer enabled, thought it would make things appear less complicated.Untitled.jpg

            • 3. Re: Movie symbol only plays first frame
              robdillon Most Valuable Participant

              In the fire movieClip you have one keyframe, the first frame, that shows the flame in sharp focus. Since there is only one keyframe, each of the subsequent 17 frames will display the same image. In other words there is no change in the flame from frame 1 to frame 18.

               

              In the main timeline, you have that flame movieClip in the layer named "Fire". Again there is one keyframe, the first frame, and the layer continues for 18 frames. You are only going to see the art in the first frame of the movieClip when you play the movieClip alone or on the main timeline.

               

              I don't know why the flame is blurred on the main timeline.

              • 4. Re: Movie symbol only plays first frame
                Mohanaraj Adobe Employee

                Hi,

                There is no animation inside the moive clip to play i.e. there is no change over frames as there is only one keyframe(first frame) followed by 17 frames of same image at same position of same size.

                Even if there is a change over frames inside the movieclip which will form an animation, you will not see the animation when you add it to the main timeline and play(Enter) it in Flash Pro as Movieclips have its own Timeline and you will only able to see the animation when you do a test movie(Ctrl/Cmd+Enter).

                 

                @ Rob:

                'I don't know why the flame is blurred on the main timeline.'

                Blur filter would have been applied on the movieclip on the Main Timeline

                 

                Thanks!

                Mohan

                1 person found this helpful
                • 5. Re: Movie symbol only plays first frame
                  Slehmann1111 Level 1

                  Converting to keyframes does  nothing

                  • 6. Re: Movie symbol only plays first frame
                    Slehmann1111 Level 1

                    When I convert the symbol to a graphic it works correctly but I need it as a movie

                    • 7. Re: Movie symbol only plays first frame
                      dharmk Adobe Employee

                      As long as your animation is setup correctly in the symbol, you should be able to use the movie clip too (in most cases). Ned has a good summary of graphic vs movie clip here - http://forums.adobe.com/message/4343294.

                       

                      Please note that while using movie clips scrubbing the main timeline wouldn't show the animation inside the movie clip. You will need to do a test movie (ctrl+enter) for previewing your animation.

                       

                      -Dharmendra.

                      • 8. Re: Movie symbol only plays first frame
                        Slehmann1111 Level 1

                        Thank you, I did not realize that they will not work in the timeline. Can someone explain why this is?