9 Replies Latest reply on Jul 20, 2013 4:54 PM by cscooper2013

    Delayed playback after editing audio in a Multi-cam Source Sequence

    cscooper2013 Level 2

      I have a Multi-cam Source Sequence (MSS).  It contains 3-cameras, only two of their audio tracks, plus two more audio tracks from separate audio recorders.  This MSS is, of course, embedded into my main timeline, where I've performed my cuts between cameras.  Playback has been beautiful and smooth until I mixed the audio levels between the various audio tracks in the MSS.  Now, back on my main program timeline, playback starts approximately 3 to 4 seconds after hitting the spacebar or L key.

       

      Some mixing was performed on the new Audio Clip Mixer.  Most mixing was done manually by adding and manipulating keyframes directly on the timeline.  I have Minimum Time Interval Thinning set to 400 ms, so that I don't get a million useless keyframes on my audio tracks when using either Audio Mixer.  For what it's worth, here's a screenshot of a portion of my MSS mix (approximately 1 minute, 30 seconds).  It is typical of the rest of the MSS timeline (approximately 40 minutes; though I've only mixed the audio for a roughly 10 minute segment so far).

       

      7-3-2013 9-31-19 AM.jpg

       

      Footage is from two Canon VIXIA HF G20 (AVCHD) cameras and a GoPro (MP4).  Again, playback was beautiful before messing with the audio mix in the MSS.  I've checked the Media Cache, Disk Cache, etc and it's got plenty of space left (around 30 GB).

       

      Playback literally feels like it's 1998 all over again and I'm working in Premiere 5.1! 

       

      Could these, relatively few, audio keyframes really be slowing me down so dramatically?  If so, can I do something to make it run faster?  If this is not the cause, what else might I be missing?

       

       

      === System Specs ===

      i7-3630qm (Laptop)

      NVIDIA GTX 670mx - 3GB GDDR5

      16GB RAM

        • 1. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
          joshweiland Level 2

          First, are you aware of the multi-cam bug in Premiere CC?  It is a very significant bug, and I would recommend not attempting a multi-cam edit in PPro CC until the patch is released.

           

          I have not yet used multi-cam in PPro CC because of this.

           

          But here's an idea: With your MSS selected, go to "Sequence" menu, then "Render audio".  Does this help?

          • 2. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
            cscooper2013 Level 2

            Josh,

             

            Yes.  I'm painfully aware of the Multi-cam bug.  This same project was delayed quite a bit because of it.  However, I've worked through those issues and patched up my multi-cam edit.  I have a love-hate relationship with CC (primarily because of the MC bug), but love it's productivity features (the ones that do work) too much to go back to CS6.  Besides, going back to CS6 was never an option for me, due to the amount of work I'd put into this project before discovering the MC bug (XML export from CC and import to CS6 was not happy). 

             

            In 5 years using Premiere Pro (since CS4), I've never tried Rending Audio.  I just never needed to.  But for this problem, yes, that was my first guess, too.  But when I choose Render Audio, Premiere just starts playing my Multi-cam Source Sequence from the beginning.  This doesn't appear to be rendering anything.  I don't get a rendering completion status bar, or anything.  Am I missing something, here?  Is this how Premiere Renders Audio, by playing back the timeline in real time?  I'm guessing not.  Is this a bug, too? 

            • 3. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
              Jim_Simon Level 8

              Have you tried a Render and Replace?

              • 4. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                joshweiland Level 2

                The only other thing I can think of...in Preferences, General, there's a checkbox to render audio when rendering video.  Check that, then choose Render In to Out from the sequence menu.

                 

                I'm away from my computer at the moment, so I'm operating from memory.  These might not be the exact wording used.

                • 5. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                  cscooper2013 Level 2

                  Thank you for all who have attempted to help resolve this issue.  Unfortunately, it's not your typical Mercury Playback issue.  The issue I'm dealing with here is a slow timeline response.  I would call it, slow screen refresh, maybe.  Here's an example.  I have a relatively simple project (it's not a 2 hour feature film).  My Current Time Indicator (CTI) currently sits at 1:00:00 (1 minute).  I click somewhere around 2:00:00 (2 minutes) and then I count to 5.  The CTI finally jumps to 2:00:00 on the timeline.  It's taking 5 seconds just to move the play head?!  I then hit the spacebar and count to 5 again.  Finally, the sequence begins to playback. 

                   

                  I did notice that from one version of my project (a few saves ago) that was around 400K, the project suddenly jumped to 1.2MB.  All I've done between the two versions was tampering with a couple dozen control points in my audio levels.

                   

                  This seems to be, for the most part, restricted to this one project.  CC seems to be slower since the 7.01 update on the whole, however.  That's my experience anyway.

                  • 6. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                    Mark Mapes Adobe Employee

                    I have a couple of hypotheses.

                    • If you  enabled the Write Keyframes control for a channel in the Audio Clip Mixer and subsequently edited any audio effects through the Effect Controls panel, then you may have inadvertently inserted untold numbers of keyframes. The easist place to look for the keyframes is the timeline on the right side of the Effect Controls panel; you wouldn't see them in the Timeline unless you had selected the parameter with unwanted keyframes from the FX menu.
                      For more information about how working with  Write Keyframe enabled can yield unexpected results, see my post in this thread: http://forums.adobe.com/message/5498625?tstart=0#5498625.
                    • if the audio channels for your multicam sequence are set to Adaptive, then you might be running into a variation of a bug that we discovered only recently. As I understand it--and I hasten to add that I'm not very conversant in the particulars--the app sometimes miscalculates  the number of audio channels in multicam sequences with adaptive audio, resulting in poor performance for certain operations, especially rendering and encoding. Whether it could also impact scrubbing and repositioning, I don't know. I also can't tell you how to check whether your multicam sequences have audio set to Adaptive. I think that if you created it through the Timeline then the audio is necessarily Adaptive, whereas when you create it through the Project panel you have a choice.
                    • 7. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                      cscooper2013 Level 2

                      My multicam sequences are usually created by Red Giant's PluralEyes.  (I would LOVE to create them with Premiere's new Audio Sync feature, but so far that only works about 0% of the time).  So the footage is synced with PluralEyes 3.2.1.  A timeline is exported from PluralEyes and then imported into a project.  Once in Premiere the sequence is only a "regular" sequence.  I know of no way to convert a regular sequence to a new sequence (that would be a cool feature; right-click on a regular sequence and choose "Convert to Multicam Source Sequence").  I create a new Multicam Source Sequence (MSS) using any two video clips.  I choose In-point for the sync.  The MSS is created and opened.  I select all on the timeline and delete.  I now have a blank MSS.  I select all from the PluralEyes generated "regular" sequence; copy; paste into the blank MSS.  Now my MSS is ready to use.

                       

                      Are you saying that audio is ALWAYS "Adaptive" when created as I've outlined above?  How can it be changed?  What should it be? 

                       

                      If I remember correctly, Premiere CC has been setting up these Multicam Source Sequences with four channels, instead of stereo.  I thought it was weird (I don't recall this happening in CS6).  So I looked into the manual and hacked my way around to reducing the channels to stereo.  Through track assignment, etc (I can't remember where) I was able to get all but one of the tracks to playback.  Ultimately that track was unimportant, so I ended up deleting it rather than continuing to fight Premiere to make the track playback audibly.

                       

                      I'll look into the link you provided above.  Meanwhile, did anything I say here spark any further ideas?  Things to try?

                      • 8. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                        Jim_Simon Level 8

                        Dude that's a lot of unnecessary work.  (I swear these new auto-generated multicam features create more problems than they solve.)

                         

                        Once you have the PluralEyes sequence imported, just nest that into a new sequence, right click and Enable Multicam.

                         

                        Done.

                        • 9. Re: Delayed playback after editing audio in a Multi-cam Source Sequence
                          cscooper2013 Level 2

                          Jim,

                           

                          Yes, it is alot of unnecessary work.  Unfortunately I only learned the method above a few weeks ago.  Also, that technique seems to leave behind the audio (both in the new sequence AND in the nested sequence).  But that's neither here nor there.  Let's stay on topic; The issue is not how I go about nesting or creating MSS-proper clips.

                           

                          Any idea why my master program timeline (not playback) is performing slowly?  This problem seems to be repeatable on both my laptop and desktop machines.