11 Replies Latest reply on Oct 23, 2013 5:39 AM by Alpine Edits

    Very , VERY Slow Render! (Sometimes has Goat Sound)

    Alpine Edits

      I'm only rendering a small 1 minute clip with about 50 layers and 36 comps all tied together with some effects and color correction.  Anyways, I usually am able to render these things like in 1-2 hours but recently it's been taking about 15 hours for 1 minute clips!  HELP!

       

      I also often get the dreaded Goat sound effect and the render fails which I have no idea what that is all about.

       

      I just bought a MacBook Pro 15" so processing should not be a problem.

        • 1. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
          Rick Gerard Adobe Community Professional & MVP

          The only thing I know about your project is that it takes a long time to render and it has a bunch of layers and nested comps. This could be normal. It depends on the composition. I know nothing about your setup except that you are running a MacBookPro. I also know nothing about how you are rendering or what codec you are using. I also don't know what version of AE you are using.

           

          I would suggest that you start by turning off MP rendering. I would also suggest that you look for differences between the comps that take a couple of hours to render and the one that takes a half a day. I'd also look at the render log for the renders that fail. The goat sound is just a warning sound that you have had a render fail. If you are using CS6 or CC then make sure you didn't turn on Ray-traced rendering.

           

          If these blind guesses don't help you'll have to give us a lot more detail about your project and your rendering solution. 50 layers with 36 pre-comps could easily take 4 or 5 minutes per frame to render.

          • 2. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
            Alpine Edits Level 1

            Hello!

             

            I'm rendering in 59.94 fps, the format is H.264 with a 30 Mbps bitrate.  Some of my layers are different fps because some clips were filmed with different camera's and some shot in 29.97 and others in 59.94.

             

            I just realized that the goat sound was due to that fact that I was trying to use a plug-in that was not properly installed so I removed the effect and now should render without problem, but it still takes a while.

             

            I absolutly need Ray-Traced because I have 3D motion tracked 3D text.

             

            I just don't understand how I've done this for the past year without problem and just started having render problems now! 

            • 3. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
              Rick Gerard Adobe Community Professional & MVP

              If you are extruding your text you need Ray-traced rendering and that could be the problem. Which MacBook Pro do you have? Do you have NVIDIA graphics? Is GPU rendering enabled?

               

              You should not be rendering h.264 from the Render Cue. You'll get a better job using the Adobe Media Encoder and multi pass rendering. It will even, in most cases, render a little bit faster.

              • 4. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                Alpine Edits Level 1

                I believe I have GPU rendering enabled and a NVIDIA graphics.  I am using 3D extruded text.

                 

                Will Adobe Media Encoder be played through quicktime, WMP (for my colleagues with PC's) and be able to upload to YouTube?

                • 5. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                  Andrew Yoole MVP & Adobe Community Professional

                  What model MacBook Pro are you using, and what model display card (GPU) does it have?

                   

                  Ray traced rendering of extruded objects in After Effects is extremely slow, depending on which GPU you are using.  Some of them, including some used by Apple machines, are not directly supported by After Effects.  Many people turn to third party plugins like Zaxwerks 3D Invigorator or VideoCopilot Element 3D to work with extruded objects, because they render much much faster.

                   

                  Adobe Media Encoder produces exactly the same type of output files as the AE Render Queue, it just does a better job of encoding them.  It also has presets for creating YouTube content etc.

                  • 6. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                    Alpine Edits Level 1

                    I have a Intel HD Graphics 4000.  I have a 15" non-retina display model.  It comes standard with a NVIDIA GeForce GT 650M with 512MB of GDDR5 memory and automatic graphics switching.

                     

                    It's not only the extruded objects that mess up my render speed (because they are only used for a small part of the video) I believe it is also Timewarp maybe?  I use a lot of timewarp and that could be a major factor, but I don't know entirely, I'm just asking questions.

                    • 7. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                      Rick Gerard Adobe Community Professional & MVP

                      Your extra long renders are caused by the extruded text. If you must use extruded text put just the text in a Ray-traced comp and nest that in a Classic Comp. Make sure to trim the extruded text comp so that it is only as long as it must be. Make sure that your GPU drivers are up to date and that AE is using the GPU to render the ray traced comp.

                       

                      The AME is the way to go for all h.264 renders. The you-tube presets are very good and easy to use. Rendering h.264 movies from the Render Cue never has been a good idea and in the CC version, this option was deprecated (removed but available again through the preferences) because it is not good for much of anything and cannot produce professional results.

                       

                      Also, make sure that you didn't starve your other apps for memory in the memory settings. I'm assuming 8GB ram, make sure that at least 3 are assigned to other applications. Timewarp can be a render hog and it may be faster in the long run to pre-render that layer to a production codec and replace the layer with the render. A temporal effect stacked up with a bunch of other layers and effects can really slow things down.

                       

                      If you make a list of all the differences between a comp that takes an hour or two to render and one that takes 15 we can probably figure out where the bottleneck is and help you solve the problem.

                      • 8. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                        Todd_Kopriva Level 8

                        After Effects will not use that GPU to accelerate the ray-traced 3D renderer. It doesn't meet the 1GB VRAM requirement:

                        http://www.adobe.com/products/aftereffects/tech-specs.html

                        • 9. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                          Evil Edison Level 1

                          Is it a goat?  I always thought it was a sheep

                          • 11. Re: Very , VERY Slow Render! (Sometimes has Goat Sound)
                            Alpine Edits Level 1

                            I complete forgot to reply because I found the problem the same day I asked it!  When making my 3D text, the frame rate of the video did not match the frame rate of the composition so the 3D Camera Tracker got screwed up.  It's fixed now!

                             

                            Thank you everyone!

                            - John