7 Replies Latest reply on Oct 19, 2013 9:15 AM by dziuminski

    IE question

    LorumIpsum Level 1

      Hi David, all looking and working well in Chrome but IE9/10 won't load main.css

      Is there a fix available?

      Thank you.

        • 1. Re: IE question
          brinaldi Employee Moderator

          Thanks for your question. What exactly are you seeing in IE? I am testing the completed files in IE10 and the CSS loads fine. Perhaps you can attach a screenshot or detail what you see in IE developer tools so we can better diagnose the issue.

          • 2. Re: IE question
            LorumIpsum Level 1

            I get a warning to allow blocked content (active X) before the page load. Tried different PCs, Laptops etc. Same result when uploaded and viewed from a remote site too. Would the webfont .js call be upsetting IE?

            Tried Capture.PNGCapture2.PNG

            • 3. Re: IE question
              David_Powers Adobe Community Professional (Moderator)

              That's Internet Explorer in its ultra-cautious mode with locally viewed files. If you click, Allow Blocked Content, it should display correctly.

               

              I don't understand why you're getting the same problem on a remote server, though. I've just tested it from my own website, and it displays correctly without complaint. However, it is possible that I changed the IE settings for my own site when originally testing.

               

              Try it for yourself: http://foundationphp.com/test/brinaldi/

              • 4. Re: IE question
                LorumIpsum Level 1

                Same here viewing yours too.

                Chrome Ok. IE as previously described.

                Enabled Active X, Javascript etc. Only happening on yours.

                Will download a fresh Zip and try again later

                 

                This won't display properly in IE either: http://www.tonydonelan.webatu.com/ (which is based on yours)

                 

                Many Thanks

                Will study your excellent DW videos again especialy with particular attention to "parent/child" and "nesting" css features.

                • 5. Re: IE question
                  LorumIpsum Level 1

                  I notice your page starts off with

                   

                  <!doctype html>

                  <html>

                  <head>

                   

                  After running the validator on it, I've changed it to

                   

                   

                  IE now seems happy with that.

                  I'm based in Ireland so am wondering if we are geographically challenged re IE protocols.


                  • 6. Re: IE question
                    David_Powers Adobe Community Professional (Moderator)

                    LOL! A very Irish solution. Sadly, it's not the answer. There is no such doctype. The one in the example files is correct.

                     

                    The problem lies with your IE settings. You're in Compatibility View. See the following screenshot taken in IE 10 with Compatibility View turned off (click on the screenshot to enlarge it).

                     

                    bayside_ie10.jpg

                     

                    Now take a look at the following screenshot, which shows the same problem as you reported. If you enlarge the screenshot, you'll see that the Compatibility View icon is blue, indicating that it's in Compatibility View.

                     

                    bayside_ie_compat.jpg

                     

                    Why the difference? Microsoft, in its wisdom (?), knows that a lot of websites aren't up to speed with the latest standards, so it introduced Compatibility View to make IE 9 and 10 work like IE 8. The Bayside Beat website uses HTML5 semantic elements, which are not supported by IE 8. That's why it looks as though the style sheet is not being loaded. It is, because you wouldn't see any of the colours if the style sheet were completely ignored.

                     

                    When I originally designed this site for Adobe, I included the HTML5 shiv, a small JavaScript file that tricks older versions of IE into styling HTML5 semantic elements. But I was asked to remove it to avoid adding complications to the tutorial.

                     

                    However, the HTML5 shiv would have no effect in your case. It can only be fixed by switching out of Compatibility View. Microsoft's attempt to make IE more user friendly has, in my view, made it less so.

                    • 7. Re: IE question
                      dziuminski Level 1

                      Hi David,

                       

                      I am having the same problem as brinaldi mentioned above.  I have built a simple website at www.coronadoinvestments.com and it (along with the Bayside Beat "completed" index.html) does not work properly in IE10 whether or not I use compatibility mode.  Is there something I can do to fix this?

                       

                      Thank you for your help.