7 Replies Latest reply on Jul 13, 2013 12:43 AM by Mark Mapes

    List of bugs fixed in the July 2013 update

    Mark Mapes Adobe Employee

      In addition to all the great features in this week’s release, many bugs were also fixed in the July 10th update. Here is a summary:

       

      Import

      • H.264 444 video files are incorrectly decoded as 422. One manifestation is green artifacts.
      • Some XDCAM 422 QuickTime clips fail to import on Mac, and imports only audio on Windows.
      • hang on quit if project contains SonyRaw Format clips imported via Media Browser
      • Crash on dragging an empty bin from Media Browser to the Project panel, with error message “[..\..\Src\ProjectActions.cpp-2653]”

      Growing Files  

      • Growing file sometimes becomes media offline while editing
      • Growing file sometimes goes offline while editing

      Capture  

      • When capture codec is set to DNxHD 145, clips captured at 1080i setting are created at 1080p.
      • If Capture panel and Edit to Tape panel are open at the same time, Capture panel will fail to capture video.
      • Capture Device in the capture window becomes Offline after closing the Edit to Tape panel
      • Crash on batch capture with tape deck connected via SDI. Error message: [..\..\Src\ManualRecorderUtilities.cpp-348]

      Export  

      • [FCP XML Export] No audio with clip if track is muted at export with XML
      • OMF Export does not trim audio properly if audio comes from multicamera sequences
      • FCP XML’s sometimes lose the correct output assignment and panning information on import.
      • Sequence previews are used during movie export regardless of the “Use Previews” Export Settings option being selected or not.
      • Some muxed h264 CBR exports are longer than the original source material
      • Duration of H264 encodes is shorter than the source by up to a second.

      Smart Render: Media from some decks does not smart render properly 

       

      Control Surface

      • Faders on control surface do not work with an adaptive clip in a multichannel sequence.
      • Some control surface faders for Clip Mixer are not updated when switching between sequences for Clip Volume value of 0.0
      • Toggle Control Surface Clip Mixer Mode button assignment provides no visual feedback.
      • Mute Buttons do not update correctly for some control surface interfaces

      Edit to Tape  

      • Edit to Tape Panel: after edit is complete, edit data remains stored in deck, and deck often remains in Insert or Assemble mode. Causes tape export failure on some decks.
      • Edit to Tape panel: “Delay Movie Start by [x] frames” is not properly honored in some case
      • Audio tracks in Edit to Tape panel do not default to A1 through A4 when switch from “Insert” to “assemble,” then back to Insert
      • Export to Tape panel: when switching from Assemble to Insert, all audio channels are selected, even when the channels are unsupported.

      Transmit: Occasional crash on toggling Transmit during timeline playback [Mac only] 

       

      Playback

      • After external I/O device is disconnected, CTI sometimes fails to move
      • after stopping playback, AVC-Intra and DVCPro HD files take 15 – 20 seconds to render frames for playback
      • Some XDCAM QT MOV clips show Media Pending graphic for extended period and exhibit poor scrubbing and playback

      Audio  

      • Various issues interfacing with audio drivers on Mac that could result in failed audio recording or playback, issues connecting to audio devices, audio issues upon the computer waking.
      • Poor quality audio when using some USB microphones in conjunction with a capture card
      • Audio distortion with audio enabled on some capture cards
      • Adaptive clips exported to Audition lose audio when channels are remapped.
      • Channel mapping of 5.1 clips exported to Audition is sometimes incorrect
      • Only the first audio channel of SonyRaw plays clips play when loaded into the Source monitor from Media Browser
      • Crash with error message “[..\..\Src\Content\AudioSequenceContent.cpp-903]”

      Timecode  

      • Timecode for some DPX clips is not handled properly
      • Premiere does not read correct start timecode from .mp4 files from some cameras

      Merged Clips: “Reveal in Project” does not work with Merged Clips 

       

      Relink

      • Media not relink-able after converting a project from CS6 to CS7: Error message “Cannot Link Media: The selected file cannot be linked because it has 2 audio channels and the clip was created with 1 audio channels”
      • “Log Note” in Clip Metadata is lost after relinking

      Sequence Settings: New Sequence from Clip: Some stereo clips yield a sequence with audio set to 10 Channel Mono 

       

      Timeline/Editing

      • The Timeline panel does not redraw correctly after audio keyframes are deleted.
      • Relevant menu options are unavailable when an empty timeline has focus.
      • Record Voice Over does not work when an Out point is set in Timeline
      • New audio tracks initialize at minimum track height in cases where they should be expanded
      • Crash on undoing a razor edit with with multiple clips selected, with error message “../Src/Sequence/PersistentGroup.cpp-108” or “../Inc/Sequence/TrackItemGroup.h-215”

      Multicam  

      • Upon flattening a multicam sequence, transitions are applied on the wrong layers. Can lead to crash with error message […Src\Sequence\Action\SequenceAddTransitionAction.cpp-57".]
      • “Extend Previous Edit”: command can result in incorrect media being used.
      • Duplicate frame indicators are shown in Multicam edits where clips from different cameras have overlapping timecode
      • When a given multicam sequence is already loaded in the Source monitor, the Match Frame command does not auto-select the correct camera
      • Multicam project lost all multicamera source synchronization after re-recording cuts then save/reopen project

      Sync by Audio  

      • When syncing by audio fails, user receives no notification
      • If a track in the Timeline contains multiple copies of a source clip, then Synchronize by Audio can sync to wrong clip
      • Syncing by audio can move audio track items that are on the same track in the Timeline but not selected
      • When one of the selected track items is a nested sequence, Syncing by audio always moves other A/V clip.

      Effects and Transitions 

      • Color at edges of crisp mattes is inverted (GPU acceleration only)
      • Effects Panel: the Accelerated Effects badges are not displayed (Windows only)
      • Error in the way dissolves are rendered with Composite in Linear Color is enabled
      • Three-Way Color Corrector does not handle Levels correctly in GPU playback mode
      • Clipping occurs with some color correction plugins at values greater that 1

      Insert Sequence as Clips: If a sequence contains a layered PSD, App crashes upon inserting it into another sequence as clips [KEM roll] 

      Metadata: Crash during metadata refresh

      Markers

      • On tabbing with an uncommitted edit in the Markers panel, the Text Edit Control sometimes loses focus
      • When playhead is on a clip marker, Clear Current Marker can instead delete a sequence marker

      Closed Captions  

      • Quicktime exports with embedded captions can have frame size problems when viewed in QT player 7 and Premiere
      • if the project contains captions, project file size grows with each save.

      Creative Cloud: CC Authentication is not remembered in some cases.

        • 1. Re: List of bugs fixed in the July 2013 update
          Jim_Simon Level 8

          Creative Cloud: CC Authentication is not remembered in some cases.

           

          I don't think you got all of that one.

          • 2. Re: List of bugs fixed in the July 2013 update
            Mark Mapes Adobe Employee

            Hence the caveat "in some cases."  Yes, I know, that clause refers not to the fix being partial but to the bug being intermittent. More seriously, every one of those bullet points could be prefaced with the caveat "Fixed _a case_ in which..." because, of course, one can rarely be sure that a fix addressed all possible causes and cases. So if anybody continues to encounter a problem that is listed as fixed, I encourage you to start a new thread detailing the specifics and, naturally, to also file a bug report. In this case, the Creative Cloud forum is probably a better place to call out your continuing authentication headaches, Jim. Unless, that is, you have this problem only with PPRO.

            • 3. Re: List of bugs fixed in the July 2013 update
              Jim_Simon Level 8

              Nope, it's for every program.  I do have a thread going at the CC forum.

              • 4. Re: List of bugs fixed in the July 2013 update
                Mark Mapes Adobe Employee

                I think it's safe to be a little more specific in the case of the CC authentication bug: the fix was specific to manually syncing settings from Premiere Pro.

                • 5. Re: List of bugs fixed in the July 2013 update
                  Jim_Simon Level 8

                  Ah, I haven't tried the new sync feature yet.  Mine is a more general bug where I have to accept the license nearly every single time I open a program - on either computer.

                  • 6. Re: List of bugs fixed in the July 2013 update
                    DMH79 Level 2

                    Mark Mapes wrote:

                     

                    I think it's safe to be a little more specific in the case of the CC authentication bug: the fix was specific to manually syncing settings from Premiere Pro.

                    Mark, I was going to start a new thread about this but since you brought up sync settings here, I'll ask...

                     

                    I just had my assistant editor finally download PPro CC since it's more ready now and I had her sync settings with my uploaded settings. It worked great. The only issue was that my computer is a 27" iMac and her's is a 15" macbook pro so when she started a new project all the windows of her new imported workspace were WAY too huge going way off her smaller screen. Is that normal? Is there a quick fix to that to make it quickly "fit" her screen? It's not the end of the world as it took just a few minutes to drag the windows around to fit, but just curious.

                     

                    Thanks for the bug list btw!

                    • 7. Re: List of bugs fixed in the July 2013 update
                      Mark Mapes Adobe Employee

                      Hmm. I never encountered this issue, so no solid answers. I can test it on Monday, but I'll wager someone else will have piped in by then.  Have you tried maximizing the main window (via the "+" button)? I can imagine that if the window is floating, it might not recalibrate to the new display dimensions (which I'd consider a bug), but I'd expect that maximizing would force it to reset.