1 Reply Latest reply on Jul 14, 2013 10:49 AM by Mike M

    update flash player on mac os x 10.5.8

    steezy7689

      i have a mac os x 10.5.8 and i am trying to update flash player but every time i try i get a message saying it requires 10.6 or higher. how can i update my flash player??

        • 1. Re: update flash player on mac os x 10.5.8
          Mike M Level 6

          Running Leopard you can't. What you have is as far as it will go.

          Leopard was the last build Mac released that was a "Universal Binary". In other words, it would run on PowerPC or Intel Processors. Once Snow Leopard was released, Adobe stopped deveopment on Universal binary builds of Flash Player.
          I know it seems like just another "money grab" by Apple and Adobe trying to force everyone to buy a new Operating System, but the entire industry has moved away from the old Apple architecture and software for it.