1 Reply Latest reply on Jul 15, 2013 5:57 AM by Laubender

    Target InDesign version

    davidDav Level 1

      Hi All,

       

      I am having Indesign CS5 and CS6 in my machine, i want to run JS in CS5, how do i target the version 

      can any one help me on this...

       

      my code:

       

      #target indesign;

       

       

       

      Thanks,

      David

        • 1. Re: Target InDesign version
          Laubender Adobe Community Professional & MVP

          @David – See page 235 of "Java Script Tools Guide CS5.pdf" for details on #target and details on "namespace" for the individual application see page 191 ("Application and namespace specifiers"):

           

          http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/indesign/pdfs/JavaS criptToolsGuide_CS5.pdf

           

           

          So:

           

          #target indesign-7.0

          should target CS5

           

          #target indesign-7.5

          should target CS5.5

           

          #target indesign-8.0

          should target CS6

           

          However I had no luck with an added locale to the version name out of the ESTK:

           

          #target indesign-7.5-de_de
          //Some alert:
          alert(app.version);
          

          should address a German InDesign CS6 but yielded an error:

           

          "indesign-7.5-de_de is undefined"

           

          The following would work, but I cannot test against a second (e.g. international) version installed:

          #target indesign-7.5 de_de
          //Some alert:
          alert(app.version);
          

           

           

          However, if you double click on a script in the Scripts Panel and you are using no #target direction the targetted app should automatically be the app where the Scripts Panel belongs to.

           

          Uwe