1 Reply Latest reply on Jul 17, 2013 7:26 AM by Amy Blankenship

    FlexUnit + Flash Player 10.2

    Amy Blankenship Level 4

      Hi, all;

       

      I'm using FlashBuilder with FlexUnit to write unit tests on my core code that is used in Flash Pro projects. We can't control or dictate what version of the Flash Player users have, so we target Flash Player 10.2.

       

      In FB 4.6, we were able to specify the Flex 3.6 version of the SDK, and, with the exception of having to download the hamcrest matchers from Drew's github account, worked fine.

       

      However, we hired an intern and one of the tasks we wanted him to work on was to try to increase our test coverage. By the time he was hired, the current version of FB was 4.7. When you try to use FB 4.7 with the 3.6 SDK, you get "unable to open 'C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\eclipse\plugins\com.adobe.flexbuilder.flexunit_4.7.0.349722\flexunitSwcs\3.6\locale\ en_US\version3locale". There does appear to be a swc there, but it's not clear exactly why this isn't working.

       

      In addition, when I select "Execute FlexUnit Tests" from the right-click menu, I get a message that the correct version of the player is not installed. I have 10.3 installed according to the Adobe site, so this suggests to me that maybe the logic in FB that understands what version of the player is being targeted is not working exactly right in this scenario.

       

      I'd appreciate any thoughts anyone could offer.