4 Replies Latest reply on Oct 8, 2007 2:45 PM by cmeans@fitdigits.com

    Get and Put not working in Fireworks

    cmeans@fitdigits.com
      The file transfer commands in Fireworks are active, since the sites have been defined in Dreamweaver, and they look like they work (the proper screens seem to pop up, but only for a second, even on large files), but I don't see any logs and the files are not actually transfered. I have to go through Dreamweavers file panel to transfer them. Any ideas?

      Thanks,

      Chris
        • 1. Get and Put not working in Fireworks
          heathrowe Most Valuable Participant
          Hey Chris, three things have to be in place.
          1. Create a site (which you have done)
          2. The Site Definition has to have a Remote Server type, either FTP or Local/Network.
          3. The source .png file has to be somewhere inside that site structure

          Most likely, 2 above is what you are missing:
          To resolve that, in Dw go Site > Manage Sites > Select your site name in the list then Edit, then in the Advanced Tab > Remote Info and set your parameters.

          Once that is set, hop over to Fw and with the png file open (that also resides in a Dw site) you will see the File Management Button activated.

          According to the Help:"Files in sites that use SFTP or third-party transport methods such as SourceSafe, WebDAV, and RDS cannot be transported to and from the remote server from within Fireworks." So this could be interrupting your file transfers.
          h
          • 2. Re: Get and Put not working in Fireworks
            cmeans@fitdigits.com Level 1
            I had to ask the system administrator about the SFTP or third-party systems, and he said no. . . I was kind of hoping that was it.

            All the rest of what you mentioned had been done. The file transfer buttons were and are active. If I do a transfer in Dreamweaver, it works just fine. But when I open the same file in fireworks, then try a Put, the file transfer screens just fly by, and no file is transfered.

            I was able to trap a screen. One says "Failed to delete file product_template_NNW2.png.LCK" - this seems to happen when I create a file locally and there isn't a corresponding file already existing on the remote server.

            When the file does exist on the remote server, I get the message '"product_template_3.png" is newer on the remote server. Do you wish to overwrite it?' - but when I press Yes, again the dialog box pops up very quickly and dissapears, and again, no file is actually transfered.

            Should I open a Tech Case with Adobe?

            • 3. Re: Get and Put not working in Fireworks
              Level 7
              Check to make sure that PNG files aren't cloaked in DW. That might be
              causing the problem.


              --
              Jim Babbage - .:Community MX:. & .:Adobe Community Expert:.
              Extending Knowledge, Daily
              http://www.communityMX.com/
              CommunityMX - Free Resources:
              http://www.communitymx.com/free.cfm
              ---
              .:Adobe Community Expert for Fireworks:.
              news://forums.macromedia.com/macromedia.fireworks
              news://forums.macromedia.com/macromedia.dreamweaver

              cmeans@ctm-design.com wrote:
              > I had to ask the system administrator about the SFTP or third-party systems,
              > and he said no. . . I was kind of hoping that was it.
              >
              > All the rest of what you mentioned had been done. The file transfer buttons
              > were and are active. If I do a transfer in Dreamweaver, it works just fine. But
              > when I open the same file in fireworks, then try a Put, the file transfer
              > screens just fly by, and no file is transfered.
              >
              > I was able to trap a screen. One says "Failed to delete file
              > product_template_NNW2.png.LCK" - this seems to happen when I create a file
              > locally and there isn't a corresponding file already existing on the remote
              > server.
              >
              > When the file does exist on the remote server, I get the message
              > '"product_template_3.png" is newer on the remote server. Do you wish to
              > overwrite it?' - but when I press Yes, again the dialog box pops up very
              > quickly and dissapears, and again, no file is actually transfered.
              >
              > Should I open a Tech Case with Adobe?
              >
              >
              >
              • 4. Re: Get and Put not working in Fireworks
                cmeans@fitdigits.com Level 1
                Enable cloaking was on, but the second checkbox to cloak files ending in png or fla wasn't checked. It also happens on GIF and JPG, I just had chosen the png since it was bigger in size (so I would see it really tranfer bytes ;).

                I unchecked the enable cloaking, exited everything, opened up Dreamweaver and the site, opened Fireworks and tried it again, on both a GIF and PNG, still nothing getting transfered.