7 Replies Latest reply on Jul 31, 2013 1:35 PM by rodsoh

    Internal Error 500 started appearing even after setting a large number for postParametersLimit




      I adopted a CF 9 web-application and we're receiving the Internal 500 Error on a submit from a form that has line items for a RMA.


      The server originally only had Cumulative Hot Fix 1 on it and I thought if I installed Cumulative Hot Fix 4, I would be able to adjust the postParametersLimit variable in the neo-runtime.xml.  So, I tried doing this, and I've tried setting the number to an extremely large number (last try was 40000), and I'm still getting this error.  I've tried putting a <cfabort> on the first line on the cfm file that is being called, but I'm still getting the 500 error.


      As I mentioned, it's a RMA form and if the RMA has a few lines say up to 20 or 25 it will work.


      I've tried increasing the following all at the same time:

      postParameterSize to 1000 MB

      Max size of post data 1000MB

      Request throttle Memory 768MB

      Maximum JVM Heap Size - 1024 MB

      Enable HTTP Status Codes - unchecked



      Here's some extra backgroun on this situation.  This is all that happened before I got the server:


      The CF Server is installed as a virtual machin and was originally part of a domain that was exposed to the internet and the internal network.  The CF Admin was exposed to the internet.




      The CF Server was hacked, so they did the following:


      They took a snapshot of the CF Server

      Unjoined it from the domain and put it in the DMZ.

      The server can no longer connect to the internet outbound, inbound connections are allowed through SSL

      Installed cumulative hot fix 1 and hot fix APSB13-13

      Changed the Default port for SQL on the SQL Server.


      This is when the RMA form stopped working and I inherited the server.  Yeah!


      Any ideas on what i can try next or why this would have suddenly stopped working after making the above changes on the server.


      Thank you