7 Replies Latest reply on Jul 19, 2013 6:12 PM by Captiv8r

    SWF files won't play in RH9

    MarionJD Level 1

      Does anyone have any idea why RoboHelp can't find a .swf file added as a link?

       

      The link works fine if entered directly in the browser, except for the warning message about the possibility of viruses, which I suspect is the problem.

       

      I added the link to a TOC page, and when I click it in the generated or published RH project, it says it can't display the webpage.

       

      Thanks for any help...

        • 1. Re: SWF files won't play in RH9
          Captiv8r Adobe Community Professional & MVP

          Hi there

           

          What is the output type?

          Where are you running the output?

          How exactly did you link to the SWF?

          What created the SWF?

           

          Cheers... Rick

          • 2. Re: SWF files won't play in RH9
            MarionJD Level 1

            Thanks, Rick,

             

             

             

            The project is output as WebHelp.  The files are stored on the same server,

            in another directory.  As I mentioned, the links work fine when played

            directly, except for the warning message.

             

             

             

            I linked by adding a TOC page and putting the link into it via the Link to:

            field.

             

             

             

            Someone else created the .swf files - I'm not sure what they used.

             

             

             

            Does that help?

            • 3. Re: SWF files won't play in RH9
              Captiv8r Adobe Community Professional & MVP

              Okay, that does help a bit.

               

              When you look at one of the links in the WebHelp, are you able to tell whether the link is actually pointing to the correct location? I know you said the files are "stored on the same server", which seems to imply that they aren't part of your WebHelp output.

               

              What does the link to one of the SWFs look like in RoboHelp?

              What are the paths involved? (Path to WebHelp and Path to a SWF)

               

              Cheers... Rick

              • 4. Re: SWF files won't play in RH9
                MarionJD Level 1

                When I Generate, the link points to file:///c:/users/...../www.[website

                address]file.swf

                <file:///c:\users\.....\www.%5bwebsite%20address%5dfile.swf> .  It's looking

                for the file in the generated project, but it looks confused. J

                 

                 

                 

                I looked to see if I could import the files, but there doesn't seem to be

                any import for swf files.

                 

                 

                 

                Can I simply put them in the directory with the project files, and point the

                link that them there?

                 

                 

                 

                I don't want to publish to see what it's looking for when it's published,

                since it's a client's site, and I don't want them to see something that

                isn't working.

                 

                 

                 

                Thanks!

                • 5. Re: SWF files won't play in RH9
                  MarionJD Level 1

                  Ah - re-reading my last message, I think I've got it.  It's looking for a

                  file:// link instead of an http://link.  I'll choose Web Address and try

                  again.

                  • 6. Re: SWF files won't play in RH9
                    MarionJD Level 1

                    Replying to myself to say that it worked!  I had assumed, wrongly, that the default would be Web Address, since that was the first on the list, but it was File.  Changed the dropdown to Web Address and added the link again, and it worked.

                     

                    Thanks for asking the right questions, Rick!

                    • 7. Re: SWF files won't play in RH9
                      Captiv8r Adobe Community Professional & MVP

                      Glad you managed to sort it!