4 Replies Latest reply on Aug 25, 2011 5:43 AM by Scott R. Hamilton

    german error messages !!!

      Hi,

      I have downloaded the English Flex 2 and 3 beta demos, and am shortly decideding to purchase it. However, the
      are some problems with using it.
      The IDE is in english, although XP is german. the problems panel gives engish error messages, but the runtime
      error messages from flash player are all in German. The locale settings in the IDE are for english.

      Please help!

      Jon
        • 1. Re: german error messages !!!
          Daryl Dean
          Flash Player is displaying German error messages because you are running a German version of Windows. If you were running English Windows, they would be in English. I would imagine that the important information wouldn't be language specific (the dump information), only the short error message like "datei nicht gefunden" and such. (My German is pretty bad.)

          I might ask why you're running German Windows if you can't read German, but that's probably a very long story.
          1 person found this helpful
          • 2. Re: german error messages !!!
            Yeah, it's because of the German XP. I'm in Germany, but my german language skills dont go as far Adobe's
            great runtime error messages.
            I've changed my system locale settings to English, everything I can do to make it think it's not german!

            There is only one download file, so it must be multilingual. There must be a way to get it to use the other locale info,
            like a switch. Debugging is very difficult. I bet Silverlight wouldn't have this problem ;-)
            • 3. Re: german error messages !!!
              floze

              I know it's quite some old topic, but rather than starting up a new one for the solution I'll post this here:

               

              Go to the folder where your mxmlc.exe is located at (roughly "c:\programme\adobe\flex builder\sdks\4.1.0\bin" for me), find the jvm.config file there, open it in a text editor, find the line where it says "java.args= ..." and append "-Duser.language=en -Duser.region=US" to it. So my line looks like "java.args=-Xmx384m -Dsun.io.useCanonCaches=false -Duser.language=en -Duser.region=US".

               

              This was the only solution that worked so far; finally the error messages appear in english language, and searching for them doesnt result in endless pain anymore. Setting all the other (system) locales and languages etc. didnt help. Btw I've found this on stackoverflow:

               

              http://stackoverflow.com/questions/1596574/flashdevelop-flex-as3-and-localized-compiler-me ssages

              1 person found this helpful
              • 4. Re: german error messages !!!
                Scott R. Hamilton Level 1

                This is essentially the java.args= xxx method which I tried, but the probem persists. Here is what I get for a 1034 error:

                 

                TypeError: Error #1034: Typumwandlung fehlgeschlagen: mx.utils::ObjectProxy@440aa41 kann nicht in mx.collections.ArrayCollection umgewandelt werden.

                 

                I understand the text but if I want to enter the message into a search machine the chances of finding something useful are infinitely better if I use the English version of the message text.

                 

                Funny, I got this to work at Flex Dev. 3 but in the Flash Developer 4.5 environment the IDE stubbornly refuses to honor these config settings