10 Replies Latest reply on Jul 23, 2013 4:08 AM by Von_Ogon

    Animated Trim Paths cannot render out - bug or else???

    Von_Ogon Level 1

        Hello everyone!

       

      I have encounted a huge problem with the exporting (rendering out) all contents of the Composition in After Effects CC.

       

      My workflow outline:

       

      1) Created a Composition of 1920x1080 size.

       

      2) Created a Solid Layer of 3840x2160 size.

       

      4) Animated Scale and Position of the Solid Layer over duration of the Composition.

       

      3) Created a Shape layer containing the Shape 1 using the Pen Tool. The Shape 1 is just an unclosed path from point A to point B

      with the Stroke of 20 px width  and no Fill applied.

       

      4) Made my Solid Layer as the Parent of the Shape Layer.

       

      5) Added  a Trim Paths to my Shape 1 in the Shape Layer (containing Stroke 1) and animated End over the Composition duration.

      I have also animated  the Stroke Width from 20 to 30 px.

       

                The Composition is playing back perfectly in Composition window inside After Effects CC:

      Animated Line is going from point A to B while the Solid Layer changing position and scale all right!

       

      6) Rendered the Composition out (using Render Que as well as Media Encorder CC) into a movie file.

       

      When I play the resulting file I cannot see my animated Shape 1 Stroke (Trim Paths) in the Exported (Rendered out) Movie file:

       

      no Animated Line is present while the Solid Layer changing position and scale...

       

       

         

      However I can see the Solid Layer animation (Scale and Position) in the Movie file.

       

      Why the animation can be seen in the Composition playback inside the AE CC but I cannot export it?

       

      What am I doing wrong?

       

      Thank you very much in advance for your advice!

        • 1. Re: Animated Trim Paths cannot render out - bug or else???
          Rick Gerard Adobe Community Professional & MVP

          Just followed your steps precicely. Worked perfectly. Made 20 paths, still worked perfectly.

           

          Try just creating a single shape layer and applying trim paths. If that works, then I suspect something with your cache and this project.

           

          If nothing else works try dragging your final comp into the new comp icon so that it is nested in another comp.

           

          BTW, I don't know what version of AE you are using, what OS you are using, or what codec you art trying to use. Make sure that they are all up to date.

          • 2. Re: Animated Trim Paths cannot render out - bug or else???
            Von_Ogon Level 1

            I am using After Effects 7 (CC).

            The OS is Windows 7 64-bit.

            Hardware: RAM: 8GB, 3TB HDD as a Scratch Disk, NVIDIA GTX460 video card.

            By the way, I cannot see the animated path even in the Media Encorder Preview window when choosing a Codec.

            I used Uncompressed AVI when rendering out straight away from AE7 (CC)...

            • 3. Re: Animated Trim Paths cannot render out - bug or else???
              Rick Gerard Adobe Community Professional & MVP

              Try just a single shape layer with trim paths. If that works, then you have a cache or comp issue. Please post a full resolution screenshot with all of the properties of your shape layer revealed. (press the u key twice). We'll take a look.

               

              Your version number of CC? is it up to date?

              1 person found this helpful
              • 4. Re: Animated Trim Paths cannot render out - bug or else???
                Mylenium Most Valuable Participant

                Could be a cache issue or something caused with your parenting since shape layers always operate in comp space. As Rick said, screenshots would help to get to the bottom of this.

                 

                Mylenium

                1 person found this helpful
                • 5. Re: Animated Trim Paths cannot render out - bug or else???
                  Von_Ogon Level 1

                  SS01.jpg

                  The size of a Solid Layer is 16712 x 9428 px to match the map size I am going to use and not 3840x2160 as I thought previously.

                  I am using a 12.0.0.404 version of After Effects CC   which is the newest one.

                   

                  This example obviously shows that the Composition Window in After Effects does not show the real output result of the composition in my case for unknown reason...

                  I can actually send this weird AE project along (it is only 78kB) as it does not have any assets exept a composition and a grey solid...

                  • 6. Re: Animated Trim Paths cannot render out - bug or else???
                    Von_Ogon Level 1

                    to

                    Just the recent update to my post:

                     

                    1) I have just opened this project in Mac OSX environment (Lion 10.7.5) and found the same issue:

                    the animated path is missing in the rendered .MOV uncompressed while clearly visible and playable in

                    the Composition window of After Effects....

                     

                    2) I have just also created an absolutely new project and a composition from scratch following my own workflow from

                    my the very first post and it the newly created project is working all right with the animated path showing in the rendered file as it is showing in

                    the Composition window... 

                     

                    But the problem still remains with the first weird project:

                    what is so wrong with the project and composition  to screw up the After Effects proper functioning?

                    I would also highly appreciate if someone from Adobe team can have a look at my mistical project...

                    • 7. Re: Animated Trim Paths cannot render out - bug or else???
                      Mylenium Most Valuable Participant

                      Rearrange your Trim Paths modifier to be before the stroke. In you screenshot it's outside the actual shape hierarchy, which might cause weird issues. All operators must be at the same level with the item they are supposed to modify.

                       

                      Mylenium

                      • 8. Re: Animated Trim Paths cannot render out - bug or else???
                        Von_Ogon Level 1

                        Many thanks to all helping me with the problem.

                        I have done the following (is that what you mean?):

                        SS02-1.jpg

                         

                        Unfortunately it has not fixed the problem... Still the same...

                        • 9. Re: Animated Trim Paths cannot render out - bug or else???
                          Mylenium Most Valuable Participant

                          Know what? You have set your shape layer to be a guide layer. That's the whole problem... Turn it off and it will work. Sorry I didn't see it earlier, your first screenshot was a little blurry in that area...

                           

                          Mylenium

                          1 person found this helpful
                          • 10. Re: Animated Trim Paths cannot render out - bug or else???
                            Von_Ogon Level 1

                            Thank you very much for solving that "mystery", Mylenium!

                            It is working now all right after I deleted the guidence attribute...

                            I had noticed that strange icon with the blue grid but could not find the explanation what it was...

                            quoted:

                            "...By default, guide layers aren’t rendered when you create output but can be rendered when desired by changing the render settings for the composition...." full stop

                            Many thanks again.