2 Replies Latest reply: Jul 24, 2013 9:54 AM by RichardSmall RSS

    Cannot save bookmarks selection

    RichardSmall Community Member

      Hi all,

       

      I have a strange little problem that is going to make me crazy.

       

      Um...crazier.

       

      Frame 11 is not saving my bookmark selections when I generate a PDF. Here's what I do:

       

      1. Save book as PDF.
      2. Select the Bookmarks tab in the PDF setup dialog.
      3. Tell it to include paragraph X.
      4. Set.

       

      All works fine. Paragraph X is included in the PDF bookmarks. But when I go back to regen the book, paragraph X is back on the Don't Include list.

       

      Frame used to save the bookmark selections...at least in the rose-colored universe I currently remember.

       

      I have tried:

      • Saving the book as something else
      • MIFing the book
      • Recreating the book
      • Uninstalling and reinstalling Frame (you know I'm desperate if I tried this)

       

      Any ideas? This is about to turn my hair straight.

       

      rich

        • 1. Re: Cannot save bookmarks selection
          Reviewer1066 Community Member

          Rich,

           

          FrameMaker stores the PDF setup in the first file of the book. So, open the first file in the book, and create a PDF with the bookmark settings that you want. Be sure to save the file after the PDF is created. Then close the file. Now try creating the PDF for the book. You should see your settings already made in the PDF setup.

           

          Caveats: I use FrameMaker 9 and have discovered that the first time I create a PDF from the book, after PDFing the first file, not all the settings are saved. I then correct the settings and PDF the book; from then on, all is well.

           

          I have also discovered in version 9 that I need to at least open the PDF settings dialog and click Yes (or OK or whatever) to make sure the bookmarks are created correctly. I never have to make changes in the dialog box, just open and save it. Maybe this is no longer the case in the newer versions of FrameMaker.

           

          Van

          • 2. Re: Cannot save bookmarks selection
            RichardSmall Community Member

            Van, you rock! Frame 11 works the same way.

             

            ...and to think I uninstalled yesterday...