4 Replies Latest reply on Jul 14, 2017 7:36 PM by rduarte64

    ADE 2 - first blank screen, finally crashes

    HarryPutnam Level 1

      setup: Win 7 64 bit

       

      I've been using ADE 2 since it came out.... but suddenly when I double click an ascm or the epub, ADE2 comes up but shows only a blank screen.  Eventually the windows error dialog shows up and says it has quit working. 

       

      The only thing I can think of that I did about this same time is get a flash update installed.  Is that likely to be related?

       

      If not, any ideas what has happened.

       

      ps - So far I have uninstalled ade2, downloaded latest and re-installed ADE2, but saw no change in behavior.

       

      PPS - Just remembered there were also a couple of windows updates today,  Including install of ie-10

        • 1. Re: ADE 2 - first blank screen, finally crashes
          sjpt Level 4

          I haven't seen that bug, but ...

           

          There are lots of bugs in ADE2.0.  Try replacing ADE2.0 with the older but more reliable v1.7.2.

          (You can have them both installed at once if you like.)

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

          • 2. Re: ADE 2 - first blank screen, finally crashes
            HarryPutnam Level 1

            sjpt wrote:

             

            I haven't seen that bug, but ...

             

            There are lots of bugs in ADE2.0.  Try replacing ADE2.0 with the older but more reliable v1.7.2.

            (You can have them both installed at once if you like.)

            [...]
            . . . . The following redirects to the same page:
            http://tinyurl.com/diged172

            [The bug referenced by sjpt above .. to summarize:

            When double click *.ascm or *.epub.  ADE2 opens but stays a blank white screen  and finally crashes.

            So cannot read at all -hp]

             

            Thank you 'sjpt', that solves my immediate problem... at least now I can read... To facilitate things I put a shortcut to version 7.2.1 in my users 'SendTo' folder: (on windows 7: 'C:\Users\MYUSER\AppData\Roaming\Microsoft\Windows\SendTo') and use that from context menu to open my books handily in ver 7.2.1.

             

            OK, but what to do about ADE2... just dump it?  I'm quite happy with the older version.

            What is the newer version supposed to do that is different or better than what 7.2.1 can do?

            • 3. Re: ADE 2 - first blank screen, finally crashes
              sjpt Level 4

              The newer version has support for multiple IDs ~ doesn't seem to work for multiple Adobe IDs (which would also be helpful), but allows vendor IDs.

              It also has support for screen readers (though there have been quite a few forum posts from people who couldn't get it to work for the book itself).

              Other than that, I don't know of any extra advantages or features of 2.0 over 1.7.2 ... there may be others.

               

              You can keep ADE1.7.2 and 2.0 on the same machine at the same time, and arrange 1.7.2 to be the default for opening .acsm and .epub files if you like.

              I do that, but hardly open 2.0 except to check answers to forum queries.

              I can't use 2.0 as my regular, as one of the many bugs is that it doesn't work with Sony eReaders on Overdrive library books, and that is my main reason to use ADE.

              For non-DRM books, I use the vastly superior and free Calibre software.

              • 4. Re: ADE 2 - first blank screen, finally crashes
                rduarte64

                It's frustrating. Apparently the problem has to do with an incompatibility between ADE 1.7 and ADE 2.0, 3.0, 3.5, 4.0 or 4.5. And is that ADE does not allow changing the directory "My Digital Editions" and hence the conflict.

                 

                In my case, solve it by uninstalling both versions (1.7 and 4.5), delete the folder "My Digital Editions" (of course saving the information of the books). Then modify the 1.7 installer by changing the string "My Digital Editions" to "My_Digital_Editions" (with underscores). Use a HEX editor.

                 

                Then reinstall both programs in the following order:

                 

                 

                1. ADE 1.7

                2. ADE 4.5

                 

                Copy the backups into the appropriate folder (with or without underscores). And ready. You have both versions working.

                 

                Greetings.