5 Replies Latest reply on Oct 18, 2013 12:49 PM by Jaysb77

    Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues

    Jaysb77 Level 1

      Hi Guys

       

      For anyone of you that is having really slow performance using AE CS6 or AECC and possibly AE CS5.5 I think i might of found out what the problem is.

       

      My System specs are below:

       

      Dell T7600 Dual XEON E5-2687W 3.1/3.8GHz w turbo / Dell M6700 i7 -3940XM 3.9GHz

      64GB Ram / 32GB Ram

      Nvidia Quadro K5000 / Nvidia Quadro K5000M

      Windows 7 x64

       

      Here are the issues I was having

       

      - Really slow performance when scrubbing along the timeline.

      - Adaptive Resoltion wasn't working at all super slow previewing

      - Multiprocessor rendering not working, or taking forever to start up, and sometimes it would work but still not the way it should it was hit or miss

      - Disk Caching not working

      - many others that I can't think of at the moment

       

      SOLUTION  for slow scrubbing of the timeline for Quad, Six and Eight core systems

       

      Here is what I figured out after hours and hours of testing and configuring. I even went back to AE CS5.5 to see if all these problems existed in that version. Although some did but not all

       

      From what I can tell it looks like certain plugins are not compatible to Quad, Six and Eight Core machines. The main plugin that has the problem is Keylight 1.2 that comes bundled now with CS6 and CC.

       

      If you turn off the plugin on your layers scrubbing the timeline speeds up and works like it should. If you want to use keylight then do the following:

       

      - under screenmatte, set the screen softness to 0

      - shrink and grow to 0.

       

      If you use any number other than these settings it causes scrubbing and rendering of the timeline to go extremely slow.

       

       

      SOLUTION  for all the issues above for Quad, Six and Eight core systems

       

      After hours and hours of testing I have come to the conclusion that AE CS6 and CC don't work well with Quad, six and eight core systems in general and especially with the keylight plugin.

       

      FIX: Go into your Bios of your computer and set your multiple core to either 1, 2 cores, theis will give you 2 thread or 4 threads. This will fix all the issues as stated below. I haven't tested 4 cores yet but soon will.

      But I know that 6 and 8 cores definitely does not work it causes all the major issues above.

       

      After setting my system to 1 or 2 cores, Ae is extremelly fast and responsive. Timeline scrubbing is super fast now even with keylight 1.2 and all it's settings. Adaptive resolution now works, Multiprocessing starts up

      immediately and disk caching is working.

       

      Conclusion

       

      I am not able to set my system to use 8 or all cores in my bios, This causes so many performance issues in AE CS6 and CC and some in even CS 5.5. I need to use either 1 or 2 cores. As you might no this really sucks when I am limiting myself to only 4 threads when I could be using 32 threads. Pleas Adobe look into this issues with these systems that have 4, 6 or 8 core systems. This could possibley just be for Dual core systems too since that is what I have here.

       

      For all of you having performance issues with AE CS6 and CC please give this a try and let me know how it works out. Hopefully you will get the same results I have.

       

      Thanks

        • 1. Re: Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues
          NilsWog

          Hi!

          I have the same problem, but I think it has something to do with PC and After Effects.

          I am the only PC user in my office and have a way faster machine then the mac guys, but After Effects is way faster on a mac with 2*Quads then mine 2*6 cores (24 Hyperthreading)

          I have also SSD disk and 64 GB RAM and a Quadro 4000K recently switched from GTX 480.

          Something happend after CS4, and pc and after effects are not good friends anymore.

          • 2. Re: Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues
            Jaysb77 Level 1

            Hi

             

            Yeah it might be a problem with the pc. What ever it is, there is definitely something wrong with this slow performance. Have you tried changing your bios settings to only use 1, 2 or 4 cores instead of your 6 cores? That's the reason why the macs are faster even though your dual 6 core machine technically are way faster. I have a dual 8 core system and I can't use4,  6 or 8 cores in ae cs6 or cc. I set my maching to use 2 cores 4 threads and it's super fast again. I bet if you set your machine to 2 or 4 cores you will get the same speed as the macs or maybe even faster. Give it a try and let me know how you make out.

            • 3. Re: Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues
              spazzblaster

              I started having this same problem yesterday when I swithched from Windows 7 to Windows 8.  I was in the middle of working on a project so I just turned multi-core processing off and AE CS6 went back to working like normal.  I can't really tell if it's faster or slower than when I had Windows 7 installed, when it was presumably actually using multi-core processing.

               

              I will change to two cores in bios and turn multi-core processing back on and tell you if I see any performance boost.

               

              I am with you.  Adobe, please fix this multi-core processing problem!  I would like to use my super expensive workstation to it's fullest potential!

               

              - Matt

              • 4. Re: Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues
                Szalam Adobe Community Professional & MVP

                spazzblaster wrote:

                 

                Adobe, please fix this multi-core processing problem!  I would like to use my super expensive workstation to it's fullest potential!

                This is a user-to-user forum. If you really want Adobe to hear you, please file a feature request. This is the only way they can actually track what their users want. And they do make changes to the software based on feature requests.

                • 5. Re: Possible Solution to AE CS6 and CC Slow Performance, Multiprocessor Rendering and Disk Cache Issues
                  Jaysb77 Level 1

                  Hi

                   

                  I may have the solution to slow performance when using multi core processing. I was testing out realflow 2013 and noticed simulations were talking a long time to finish when using maximum threads 32. I set the threads to 8 and the simumlation was twice as fast which did not make any sense to me. The simulation was taking 1min 24 secs to finish using 32 threads and 45sec using 8 threads. I realized their has to be a problem here. So I went into my BIOS and disabled Hyper Threading. So now instead of having 32 threads I only have 16 threads. When i went back to try the same simulation again this time the 16 threads was only taking 24secs to finish. and the 8 threads was taking 35secs to finish. This made a lot more sence to me.

                   

                  Anyway so once I realized that turning off Hyper Threading fixed my simulation problem maybe it might be the cause of my slow performance in AE using multi processing. I tried AE and now multi processing is working great very fast now and stable. MP renders start right away now instead of getting stuck on frame 2 or saying initializing background processes and never ever doing anything. Before I had to keep disabling MP and re-enabling it in AE to get it to start working again and still it wasen't very stable

                   

                  If anybody is having issues with slow performance from their Multi processor systems try disabling Hyper Threading in the BIOS it might just fix your problem.

                   

                  Hope this helps