20 Replies Latest reply on Aug 20, 2013 9:32 PM by JaysonM-Y

    choppy playback on TV-out PP5.5/CUDA/Windows

    bunkermad

      Hello everyone,

       

      first of all please note I have been editing for decades and was among the very first to use NLEs in the days of AVID (more than 20 years ago) - suffice to say I was there and saw it when Premiere came out at v. 1.0. (yes, I am that old)

       

      All this to say that you do not need to address basic issues as I know my stuff - also please no obvious comments on my setup: I know it is on the weak side but I have reasons for the equipment I have.  Which consists of PP 5.5.2 running on a Win Vista 64 with an Athlon II X4 645 (O/C to 3.4GHz), 8GB RAM and U320 scsi disks (with cache and previews on a third disk) with an nVidia GTX260 and GT240.  Main monitor is an LCD on GTX260 with playback fullscreen on a broadcast CRT via S-Video from the GTX 260.  The idea was that I figured CUDA would take care of scaling down and re-interlacing HD video for playback on the PAL monitor.

       

      I work with AVCHD (50i, full HD @ 17Mbs) and of course I have the Mercury GPU enabled (ehm...), had it all setup to go dreaming yet much to my dismay I noticed PP is struggling to play video smoothly, especially when the PAL monitor is involved.

       

      1) AVCHD playback on the computer monitor is OK (struggles a bit sometimes but generally allright), however scrubbing video is a pain, slow and erratic, missed frames, slow etc.;

       

      2) playback on TV is CHOPPY, I'd say I am getting 12-18fps (basically it seems to skip one every two or three frames, the motion isn't fluid at all)

       

      3) I get the yellow bar on the timeline (except for dissolves and effects where it's green - at least my GPU is working)

       

      4) I can tell the TV monitor has some kind of de-flickering applied by the nVidia driver but I just can't find a way to switch it off, and I think that's causing problems since Premiere identifies the TV as 720x576p when really it should be a 720x576i - actually it should be 768x576 because it's analogue, but go and tell nVidia engineers.

       

      5) I have noticed even DV files are choppy on the TV/PAL monitor, whereas they play beautifully on the computer monitor, so it doesn't seem to be an AVCHD issue but rather PP and nVidia not really talking to each other (or maybe nVidia not listening on the TV side) - NOTE: when playback is set on the TV/PAL monitor, DV playback in the program window on the computer IS ALSO CHOPPY.  But if I switch off playback on the PAL/TV monitor, DV playback on the computer monitor is beautiful.

       

      If I play one of the AVCHD clips on the EXCELLENT media player classic (MPC-HC v. 1.6.7), they play absolutely like sweet butter both on the computer monitor AND on the PAL monitor (bar the 'softy' image due to the stupid nVidia driver de-flickering what is an interlaced video being played on an interlaced monitor - what is wrong with nVidia engineers?)

       

      So to cut a long story short, can some please help, if they can, identifying the culprit of this situation and killing it?

       

      I know I should upgrade the processor (and may just do that, however a Phenom II x4 is the maximum my current MB can take, and so is 8GB RAM), but is it going to help?  It seems the main problem is having video playing smoothly on the PAL monitor, so it seems a video/CUDA/PP issue more than a CPU issue, but you tell me...

       

      I am turning to you since I have been banging my head on the web about this for weeks now and I am at my wits' end.

       

      Cheers!

        • 1. Re: choppy playback on TV-out PP5.5/CUDA/Windows
          Jim_Simon Level 8

          My own estimation is that for working with AVCHD, you need a whole new system, preferably something based on the i7 4770 or i7 3930.  That new system should also include an HD set for outside monitoring.  An SD set for the purpose is pointless.  Though you should keep it for DV monitoring, as it will do a better job than most HD sets.  However, you might want to look to a proper I/O solution rather than the S-Video out of the GPU, which never did work properly for Adobe tools.

          • 2. Re: choppy playback on TV-out PP5.5/CUDA/Windows
            bunkermad Level 1

            Hi Jim,

             

            apart from the fact that based on Adobe specs this configuration (aside from the 'unsupported' video cards) is suitable for HD (remember I am running 5.5, not 6), as I said I am not in a position to overhaul the whole computer at present, apart from upgrading to a faster CPU.  Besides, I have reasons for sticking to previewing on a CRT, two of which are  chroma and interlacing, which you can't get properly on LCD or plasma unless you dish out considerable sums of money for a reference HD monitor.

             

            Incidentally, if I disable the Mercury GPU engine, I can playback AVCHD in realtime via Firewire and a DV converter onto the CRT monitor and it looks spot on - bar high definition of course.

             

            Interesting to hear that the S-Video output has a bad reputation with Adobe software - maybe that's the wall I am hitting?

            • 3. Re: choppy playback on TV-out PP5.5/CUDA/Windows
              Jim_Simon Level 8

              'Suitable' and 'snappy' are two veeeery different scenarios.  You seem to want the latter out of the former, and it just ain't gonna happen.

               

              I get the interlacing thing, which you'd want for your DV projects.  But with the death of CRT, HD is pretty much always deinterlaced anyway, by which I mean even when the signal is interlaced, it's deinterlaced before the viewer actually sees it on any HD set, so there's not much need to worry about an interlaced display for HD monitoring.  The greater need is for the resolution of HD and the increased color space of HD.  You will get neither on an SD set, so they're useless for HD monitoring.

              • 4. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                bunkermad Level 1

                OK thanks, but your comments are not helping me solve the problem.  I need to playback full screen on a second (PAL) monitor, and it's choppy, whether SD or HD. What gives?

                 

                Incidentally if I playback to the third monitor (1024x768 runing off the GT240), AVCHD is better but still a little choppy, and DV is OK although not perfect if I keep 'Desktop Video Display During Playback' enabled.  Is perhaps because I am using two video cards on three displays?  Is this too much for Premiere?  Even when I was using CS3 for DV I had problems getting the video to playback smoothly on the PAL monitor when using nVidia drivers & cards - maybe that's where the issue is.

                 

                I need to ascertain what is bottlenecking this, my system CAN cope with HD material, it's playback full screen on a monitor other than the main one that is being affected, especially if it's an interlaced dsplay.

                 

                P.S. I never said I want a 'snappy' system, all I want is video to play smoothly full screen on an external monitor.

                • 5. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                  Jim_Simon Level 8

                  Again, it seems as if you just don't have adequate hardware for the job.

                  • 6. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                    bunkermad Level 1

                    "Again, it seems as if you just don't have adequate hardware for the job."

                     

                    Again, I'll repeat what I said:

                    I need to playback full screen on a second (PAL) monitor, and it's choppy, whether SD or HD.

                     

                    I'll repeat it again: whether SD or HD.

                     

                    In other words: even DV playback on an external monitor is choppy.

                     

                    I hope that's clear.

                    • 7. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                      Rallymax-forum Level 3

                      Can you check output with NTSC?

                      A long time ago I remember that nvidia makes USA only (NTSC) and International (PAL+NTSC) drivers.

                      The international ones had problems.

                      Perhaps it is this driver to your s-video output that is the problem.

                       

                      DV playback should be a good benchmark for you. It has worked for machines 10 years older so processing power should not be a problem.

                       

                      I can understand the AVCHD editing experience not being underpowered with your system but DV should have no problems at all.

                       

                      Btw wrt 4) 720x576 is correct because of the 1:1 pixel aspect ratio pf PAL monitors with analog 768x576 0.919:1 ratio.

                      • 8. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                        JaysonM-Y Level 3

                        Ever tried just turning off MPE to see what would happen?

                        • 9. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                          bunkermad Level 1

                          Thanks Rally, that could make sense and I could try it (my CRT does take an NTSC signal), however all my source files are in PAL or 50i format so that would bring additional computation to convert them to NTSC in real time, which wouldn't help with testing.

                           

                          I do think there may be an issue with the nVidia drivers, which is why I am here in case someone else had a similar experience.  I have tried with v. 195 and v. 296, to be honest I don't see the point of upgrading to the most recent, they are optimised for the latest hardware and software, I very much doubt they would bring any benefit to my setup and probably add more 'bloatware'.

                           

                          I agree DV should be absolutely fine, as I said it is if I stick to the main computer monitor, but as soon as I elect playback fullscreen on the TV-out, it is choppy both on the CRT and the computer monitor - to a lesser degree a similar experience also when electing playback on the second computer monitor, which is driven by the other nVidia video card.

                           

                          Sorry but the proper PAL format for analogue is 768x576 square pixels (CRTs have phosphors).  It's the CCIR digital format that made that into 720x576 rectangular pixels when they introduced digital video, I think they did it as a middle ground between NTSC (640) and PAL (768) - in fact one of the digital formats is 704 horizontal - except that us on the PAL side lost out on horizontal resolution!  720x576 is for PAL as a digital recording file format (rectangular pixels), 768x576 (square pixels) is the digital equivalent of the analogue playback signal for monitors. Trust me on that.

                          • 10. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                            bunkermad Level 1

                            Thanks Jayson, I did think of that and will test it shortly.  It may well have something to do with it, because if I keep MPE on I can't get DV playback via Firewire, if I switch it off it's fine - even with HD material which is amazing.

                            • 11. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                              Jim_Simon Level 8

                              I hope that's clear.

                               

                              It is, and my answer stands.  Your method of getting the signal onto the monitor is insufficient.  You may need better hardware.  Something from AJA, Blackmagic, Matrox or Bluefish, for example.  Or for SD playback, maybe something like the ADVC110 from Canopus connected via FireWire.

                              • 12. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                bunkermad Level 1

                                I am sorry but I totally disagree with you, and I don't think you understood the problem yet.  Forget HD, are you tellng me that a quad-core on a 64-bit system with 8GB RAM and two recent PCI-express video cards running CUDA are not sufficient to playback DV fullscreen on an external monitor??? Apart from the fact that on paper that is enough, I was achieving EXACTLY THAT on a dual-core at half the speed with half the RAM on a 32-bit system with an AGP ATI card and Premiere CS3.

                                Not forgetting that I can play HD full screen on the external monitor using plain media player classic, as I said earlier.

                                 

                                So unless you have a more practical suggestion, could you please refrain from the usual habit of throwing money at a problem and simply blaming hardware limitations.  Thank you.

                                • 13. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                  Jim_Simon Level 8

                                  I'm telling you that PP has never been very good sending a signal out via a graphics card's 'video' output.  You might do better with HDMI out or VGA.

                                   

                                  You will almost certainly do better with FireWire.

                                   

                                  And no, I will not refrain from suggesting better hardware when I feel it's an appropriate suggestion.  I don't say it's the best or only solution, just likely a viable one.

                                   

                                  The thread remains open to other ideas as well.

                                  • 14. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                    bunkermad Level 1

                                    I'll take that point, I suspected this was not necessarily a CPU-related issue.  However it may be that PP is only partly to blame, and nVidia has more responsibility.  On my old setup as I said PP CS3 was fine at DV playback full screen on the TV-out when I was using an ATI card, but when I switched to nVidia Geforce it deteriorated, even though the specs for the new card were higher.  ATI had much better control at TV-out, you could also vary the amount of de-flickering or turn it right off (which was perfect and absolutely right for full-screen interlaced video), whereas you just can't do that with nVidia, and I am sure that adds a layer of complication and extra computation when viewing interlaced material on an interlaced monitor - what is going through nVidia engineers' mind?

                                     

                                    I would also say to you that even though HD has progressive formats (and all HD televisions can display it), I still shoot at 50i and it is a requirement for all TV broadcasters, as the DVB signal is still interlaced.  It also works better when outputting to Mpeg-2/DVD, and it generally works better because it gives you fluid motion without the heavy data load of 50p.  They made interlaced for a reason with analogue TV, and that reason is still a good one also with HD.

                                     

                                    As I said to you I do have a firewire AV converter, and that works a charm except PP 5.5 requires you to switch off MPE for firewire to work, which is a shame (I believe that issue has been put right with CS6).  At the same time, it's good for playback but isn't great for editing, as I have noticed the firewire signal is lost and found as I scrub the timeline, trim or do other editing operations. It is already quite an achievement (and a feast to watch) to playback HD downconverted to DV stream in real time, so perhaps the experience would be improved with a faster CPU.

                                    • 15. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                      bunkermad Level 1

                                      UPDATE

                                       

                                      OK, I've done a few more checks and can now simplify the issue.  I have connected an external HD monitor via HDMI to the secondary video card (an nVidia Geforce), also disabling the other computer monitor, so the only monitor connected to this card is the HD one via HDMI.

                                       

                                      With AVHCD with or without MPE (slighlty better with MPE):

                                      - playback at any window size, all resolutions and fields on the primary computer monitor ONLY is absolutely fine;

                                      - playback on the HDMI monitor ONLY is choppy;

                                      - playback on the primary computer monitor AND the HDMI monitor at the same time is choppy;

                                      - playback using Media Player Classic x64 is perfect on any monitor, any resolution (only marginally worse on full screen on the HDMI monitor)

                                       

                                      With DV, same behaviour, with the added mistery that without MPE the image is more pixelated, as if the software automatically lowers the playback resolution.

                                       

                                      I really can't figure this out, if the CPU was not good enough I would expect to get choppy playback in all instances, instead I only get it as soon as playback is directed to a monitor other than the primary one, whether playback is enabled on the primary one or not.  Conversely, if it was a CPU problem I would expect DV to behave much better, instead it is almost the same, plus a pixelated picture with MPE off.

                                       

                                      If somebody has got any clue or suggestion, please come forward.

                                      • 16. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                        bunkermad Level 1

                                        UPDATE 2

                                         

                                        OK I have chatted to both nVidia and Adobe, pretty much both of them rather inconclusive.

                                         

                                        nVidia: my main chat was to do with how to disable the anti-flickering on the TV-out, well the guy said it is not possible anymore, so I gave up; but low and behold, whilst searching again on the net, I came across the notion of a 'flicker filter' in nVidia Control Panel, in a section where I had never thought of looking (Desktop Colour Settings), and there it was (so much for nVidia tech support guys), so presto I lowered it to ZERO and finally all my interlaced video, be that HD or SD is finally displaying properly on the CRT.  However, the jerky motion remains, much to my dismay since I thought the 'flicker filter' was  negatively affecting performance. Well it isn't, it just makes interlaced video look rubbish on an interlaced monitor, but it's still in real time, so whether it is enabled or not it doesn't affect motion playback quality.  One step forward at least, but I'll have to get back to them again.

                                         

                                        Adobe: I also had a chat with an Adobe tech support guy, and he suggested to drag the whole program (or source) window onto the TV-out display.  Result: same jerky motion.  Drag it back onto the primary monitor: perfect.  So he said this is a known problem to do with using monitors with different resolution, and that it s a driver issue.  Of course he suggested updating the nVidia drivers, which I queried, because I was already using recent ones, and my video card not being recent I doubted they would have had much improvement.  Anyway I updated the drivers to the latest and it made no difference.  Thanks Adobe.

                                         

                                        Finally I tried again electing the secondary computer monitor (via VGA) as playback monitor, and there is a noticeable improvement, still not perfect but certainly passable.

                                         

                                        So, what is it? Insufficient hardware? Maybe, but then why does HD play fine on the primary monitor, and even DV is jerky on the interlaced display?  A software issue? I would be more inclined to think that way.

                                         

                                        Comments welcome.

                                        • 17. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                          bunkermad Level 1

                                          SOLVED! (almost)

                                           

                                          Well it seems no-one's very interested in this, but I have actually found one way to massively improve playback on external interlaced monitors and fix the jerky motion on all video files.

                                           

                                          I noticed that Vista was alerting me to a video perfomance degradation due to "Video memory resources are over-utilized and there is thrashing", Event ID 500. I noticed in the log there were loads of these entries, so I searched the Internet and found one particular instance of a guy with an identical warning AND choppy video playback.  He said he switched off Vista's AERO interface and warnings were gone with smooth video playback.  So I disabled AERO by enabling the Vista Basic Theme, and noticed IMMEDIATELY a snappier desktop.  Premiere launched in flash, I played out the timeline to the interlaced monitor and VOILA'!!!!  SMOOTH PLAYBACK ON THE CRT!!!!!

                                           

                                          To be very honest, it does hesitate a tiny bit every once in a while, and obviously AVCHD timeline scrubbing is not really better, so I may still have to upgrade to a faster processor even though this wasn't the main reason - I calculated I will only improve by about 30-40% with the fastest I can install on my motherboard.  However playback now is smooth and I have nailed the main bottleneck that was affecting interlaced playback via S-Video or HDMI.

                                           

                                          This was probably also the result of a combination of less-than-ideal hardware, like a processor without L3 and SSE 4.x, video cards with low DDR3 RAM,  limited system RAM (and probably Vista being rubbish), but it proves that my gut feeling that a SOFTWARE issue was the main culprit.

                                           

                                          I will update further as I do more testing, but for now if anyone has playback problems on an external (interlaced) monitor with PP 5.5, Vista 64, and less than ideal hardware, the simplest thing to do is disable the AERO interface (and as many of the background system processes as possible), and all should be fine.

                                          • 18. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                            Rallymax-forum Level 3

                                            That makes a lot of sense. The Aero interface puts quite a load on the GPU and thus the PCI Express bus to/from main memory too.

                                            You could simply be running out of bandwidth on the motherboard (or the DRAM is slow eg 800MHz) thus why you never saw high usage of CPU or GPU.

                                            I hazard to guess that if you added another GPU card and tried to run the second-monitor from that it might solve your problems. If you have one handy and a PCIe slot free it might be worth trying.

                                            • 19. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                              bunkermad Level 1

                                              Weird, I don't remember saying that CPU/GPU usage wasn't maxing out, but yeah that was the case.

                                               

                                              Anyway I am already running a dual video card setup, the HDMI monitor was connected to the secondary card - however that was no good too, yet the secondary computer monitor (VGA) connected to it was OK.  It seems that as long Premiere is addressing the same 'video space' as AERO it's OK, as soon as it starts to grab an external (interlaced) display for its own exclusive use it has a fist fight with AERO!

                                               

                                              I take the case of the bandwidth, the motherboard and chipset are a little old, system RAM is only DDR2 and video cards only have 1GB of DDR3, definitively a case of bottlenecking as I imagined.

                                               

                                              I even benchmarked my computer after this latest 'cleanup' and it scores allright actually, not the best of course but it's faster than similar systems.

                                               

                                              Anyway it's OK now, I'll soon upgrade the processor to max out the performance but I can work with this, and then next year I'll just change the whole setup.

                                              • 20. Re: choppy playback on TV-out PP5.5/CUDA/Windows
                                                JaysonM-Y Level 3

                                                Vista... that's right in line with the version of the adobe suite I despise the most... CS4.
                                                I've been running my systems on "Adjust For Best Performance" gray-bars no animations look for so long, I figured it's the first thing people do when installing the Adobe Suite.

                                                LOL once again from CS4 days...

                                                The only reason I don't do it on OSX as well is because they don't give me the option to.