3 Replies Latest reply on Aug 7, 2013 4:08 AM by kid1ng Branched from an earlier discussion.

    audio output with aerender

    kid1ng

      I'm encountering a strange behavior on CC's aerender that becomes different depending on the presence of ae_render_only_node.txt, even if it's not supposed to.

      I've made an example project called test.aep, with a custom output module called "QTAudioOn," with "Audio Output On" to have an audio track every time something gets rendered.

      1.png

       

      test.w_node.mov is when there was ~/Documents/ae_render_only_node.txt, test.wo_node.mov is when there wasn't. In the same configuration, the yielded files came out different.

      2.png

       

      test.w_node.mov was missing an audio track, that is supposed to be silent track according to the output module configuration.

      3.png

       

      It seems test.w_node.mov was created using "Audio Output Auto" output option which was newly introduced with CC. The same process was never a problem with CS6. This problem frustrated me since we concatenate videos in order and merge the audio with other audio track programatically using MP4Box and ffmpeg. Missing audio track scrambles the result video in concatenation process.

       

      Is there any way to fix this problem? Maybe I could make silent track using ffmpeg, but it seems too much.

       

      Thanks.

      Don.

       

      Edit: test.aep consists of only one red solid object, nothing else.