3 Replies Latest reply on Oct 5, 2007 10:47 AM by kglad

    Load external image problem

    dsmflash
      I am building a simple photo gallery. Each gallery category (ex: nature, fine art, etc.) is a seperate swf loaded into main interface. Within each of the seperate swf files, i have an empty loader clip to load large image. All of my thumbnail images are in movie clips. Within the thumbnail movie clip, i have in the first frame of the actions layer:

      th1_mc.onRelease = function() {
      _root.loader_mc.loadmovie("/assets/family/1b.jpg");
      };

      However, when I test movie, I get no errors but my image will not load into the empty movie clip. Can someone help me.
      Thanks in advance.
        • 1. Re: Load external image problem
          kglad Adobe Community Professional & MVP
          _root references one timeline when you test your external swf without loading it into your main swf, and it references a different timeline when your external swf is loaded into your main swf.

          you can probably quickly remedy your issue by using the following in your external swf's:

          • 2. Load external image problem
            dsmflash Level 1
            Thank you. I replace _root with _parent (duh) and works perfect. I will implement your method when I load the external swf. I do have another question, how do I center my image in the empty movie clip? When I change the reg point to center, it moves it way down to the lower right hand side of stage.

            Thanks
            • 3. Re: Load external image problem
              kglad Adobe Community Professional & MVP
              you're welcome. but if you're not using _root in your external swfs (because you replaced them with _parent), you need not use _lockroot.

              _parent will reference the same thing in an external swf as it will in your main swf (as long as it's not on the external swfs main timeline).