8 Replies Latest reply on Dec 3, 2007 3:53 AM by Newsgroup_User

    Installation oddity - issues with eclipse folder

    user411
      I'd like to start by thanking Adobe for releasing Flex Builder for Linux. It's much appreciated!

      The problem system is running Ubuntu 7.04 with a fresh Eclipse 3.3.1 install, with cdt and wtp on top. The 1.5 Java JRE has been installed with apt-get and added to the PATH. Eclipse 3.3 is located in my home directory and configured to use the new JRE. An Eclipse 3.2 install from apt-get is also on the system.

      Starting the installer with 'sh flexbuilder_linux_install_a1_100207.bin', I get to the point of selecting the Eclipse folder, and after analyzing the selection, the installer comes back with a message titled "Eclipse 3.3 (or higher) not found" that says "This root folder must contain a subfolder named "configuration"...". The directory I'm submitting is /home/myuser/eclipse and it's a standard install with a configuration directory, so I click the "Proceed with Caution" button, and away it goes.

      However, once the install is completed, it always informs me there have been errors. Seven errors are of the form:

      !ENTRY org.eclipse.update.core 4 0 2007-10-06 10:17:53.123
      !MESSAGE Error retrieving "feature.xml". [error in opening zip file]
      !STACK 0
      java.util.zip.ZipException: error in opening zip file
      at java.util.zip.ZipFile.open(Native Method)
      at java.util.zip.ZipFile.<init>(ZipFile.java:203)
      ...

      And one reads:

      !ENTRY org.eclipse.update.core 4 0 2007-10-06 10:17:53.146
      !MESSAGE Cannot install featurecom.adobe.flexbuilder.feature.core.linux 3.0.183693
      !STACK 1
      org.eclipse.core.runtime.CoreException: Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
      at org.eclipse.update.internal.operations.BatchInstallOperation.execute(BatchInstallOperatio n.java:50)
      ...

      eclipse/configuration gains a com.adobe.flexbuilder with files inside, but in Eclipse, Window -> Open Perspective -> Other... does not list a Flex Builder perspective, and I cannot figure out how to start a Flex project.

      Any feedback would be great. It seems like there must be something obvious getting overlooked. I can't wait to switch my development platform to Linux!
        • 1. Re: Installation oddity - issues with eclipse folder
          Level 7
          Can you check if this
          http://codetouch.blogspot.com/2007/10/installing-flex-builder-linux-alpha.html
          helps you for now (time being, before we dig into the problem causing
          you to stop using flex builder)...
          • 2. Re: Installation oddity - issues with eclipse folder
            user411 Level 1
            I have read your article, and thanks for writing it. I used it during my second and third tries at installation.

            The differences between my install and what you recommend are that my JRE 1.5 came from Ubuntu's apt-get.

            I don't understand why the Flex Builder installer does not recognize/accept the Eclipse directory specified.

            Please let me know if you have any other ideas on what's going wrong.
            • 3. Re: Installation oddity - issues with eclipse folder
              Level 7
              >>>> The differences between my install and what you recommend are that my JRE 1.5
              came from Ubuntu's apt-get


              [Arun] Hope it is SUN JRE 1.5 and not gcj version of JRE. Use ./java
              -version to verify the same...

              >>>I don't understand why the Flex Builder installer does not
              recognize/accept

              the Eclipse directory specified

              [Arun] Can you try to download Eclipse 3.3 from the locatoin given in my
              blog... This is just to confirm if there is anything specific that is
              going wrong with apt-get? may be it is getting Eclipse 3.3.1 !! not
              sure... please do try the URL i have given to download Eclipse 3.3 and
              start the installation.

              Also, please try to create a directory in the $USER_HOME/ directory
              instead of /opt. I am not sure if you have permissions on that directory
              for every one !

              ~ Arun

              user411 wrote:
              > I have read your article, and thanks for writing it. I used it during my second
              > and third tries at installation.
              >
              > The differences between my install and what you recommend are that my JRE 1.5
              > came from Ubuntu's apt-get.
              >
              > I don't understand why the Flex Builder installer does not recognize/accept
              > the Eclipse directory specified.
              >
              > Please let me know if you have any other ideas on what's going wrong.
              >
              >
              • 4. Re: Installation oddity - issues with eclipse folder
                Level 7
                I just read that you are having Eclipse 3.3.1.... may be thats the
                reason it is not detecting... It works fine for the released version of
                Ecilpse 3.3 (Can you verify)??
                If you are facing this with Eclipse 3.3.1, please feel free to file a
                bug in the bug-base http://bugs.adobe.com/jira (Flex builder linux)...
                Also, please note that Eclipse 3.3 is the only supported version for
                this alpha release..

                ~ Arun
                • 5. Re: Installation oddity - issues with eclipse folder
                  user411 Level 1
                  Thanks for the reply.

                  Installing Eclipse 3.3 flat solved the issue. For some reason I thought I'd read 3.3 or higher somewhere...and in fact I had. The installer explicitly states "choose an exisiting Eclipse 3.3 or higher root folder...". You guys might want to fix this. :)

                  For others edification, the JRE that comes from Ubuntu Fiesty's apt-get install sun-java5-jre returns this to java -version

                  java version "1.5.0_11"
                  Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
                  Java HotSpot(TM) Server VM (build 1.5.0_11-b03, mixed mode)

                  Thanks for all the help Arun. I'll log this as a bug.
                  • 6. Re: Installation oddity - issues with eclipse folder
                    user411 Level 1
                    After waiting 30 minutes to get accepted to report bugs, and another hour to try and login, you bug reporting system will not accept the username/password I set up. Please consider the bug reported.
                    • 7. Re: Installation oddity - issues with eclipse folder
                      Level 7
                      user411 wrote:
                      > After waiting 30 minutes to get accepted to report bugs, and another hour to try and login, you bug reporting system will not accept the username/password I set up. Please consider the bug reported.
                      >
                      Hi,

                      Sorry for that.. Looks like the bug reporting system was under
                      maintenance for sometime not sure though... But yes. We appreciate your
                      feedback and we shall work on that asap.

                      Thanks again,
                      ~ Arun
                      • 8. Re: Installation oddity - issues with eclipse folder
                        Level 7
                        user411 wrote:
                        > Thanks for the reply.
                        >
                        > Installing Eclipse 3.3 flat solved the issue. For some reason I thought I'd
                        > read 3.3 or higher somewhere...and in fact I had. The installer explicitly
                        > states "choose an exisiting Eclipse 3.3 or higher root folder...". You guys
                        > might want to fix this. :)
                        >
                        > For others edification, the JRE that comes from Ubuntu Fiesty's apt-get
                        > install sun-java5-jre returns this to java -version
                        >
                        > java version "1.5.0_11"
                        > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
                        > Java HotSpot(TM) Server VM (build 1.5.0_11-b03, mixed mode)
                        >
                        > Thanks for all the help Arun. I'll log this as a bug.
                        >
                        >
                        Ooops.. I just verified that any higher versions of Eclipse 3.3.x.x or
                        anything works fine with the installation of the FB Alpha. If you are
                        using ubuntu then i am guessing they supply only Eclipse 3.2 and nothing
                        higher?? not sure but i just found out that even ubuntu 7.10 also
                        bundles eclipse 3.2 by default and not the further latest versions of
                        eclipse ... you may want to check on this...

                        I am marking your bug as Not a bug and resolving the same...
                        http://bugs.adobe.com/jira/browse/FBE-211

                        Ping me if you have any other problems with the same....

                        Thank you,
                        Arun