3 Replies Latest reply on Mar 14, 2008 2:40 PM by

    Search not Working

    C-IMS
      robohelp x5 javahelp html
      2 separate projects - both until recently compiled and worked properly.
      now in 1 of them the search no longer works. As other projects work ok i'm assuming its not a dll or anything that is missing.
      when compiling the one that doesn't work i notice i'm now getting compile errors as below. i've compared the project settings and both are set the same, although the second one has had many more topics added at last release. does anyone have any ideas?

      Building Full-Text-Search data...
      java.lang.ArrayIndexOutOfBoundsException: 255
      at com.sun.java.help.search.BtreeDictCompactor$CompactorDictBlock.restoreKey1(BtreeDictCompa ctor.java:31)
      at com.sun.java.help.search.BtreeDictCompactor$CompactorDictBlock.doMap1(BtreeDictCompactor. java:43)
      at com.sun.java.help.search.BtreeDictCompactor$CompactorDictBlock.doMap1(BtreeDictCompactor. java:56)
      at com.sun.java.help.search.BtreeDictCompactor.compact(BtreeDictCompactor.java:210)
      at com.sun.java.help.search.DefaultIndexBuilder.close(DefaultIndexBuilder.java:91)
      at com.sun.java.help.search.Indexer.compile(Indexer.java:231)
      at com.sun.java.help.search.Indexer.main(Indexer.java:76)
        • 1. Search not Working
          My search isn't working now either, and I'm not getting any errors. Did your issue get fixed? How did you do it? I search for anything and get "no topics found". I'm running in 7.01.001 and building both html and webhelp. The webhelp search works just fine after I compile it, but the html search shows no topics found.

          sstahl@resortdata.com
          • 2. Re: Search not Working
            Pete Lees Level 2
            Hi Suzette,

            I believe you need to re-register one or more of the components that the HTML Help compiler uses to assemble the full-text search "database" for your help file. See this thread in another forum:

            http://helpman.it-authoring.com/viewtopic.php?t=6591

            It's odd how often this issue has come up in lots of different Help forums in the last month. Perhaps a recent Windows update has inadvertently broken the registry settings for these compiler components.

            Pete
            • 3. Re: Search not Working
              Perfect. Thank you. I ran the report and found that the the html help workshop was missing a .dll. Reinstalled and now working fine. Thank you!!!