8 Replies Latest reply on Aug 14, 2013 6:49 AM by anoopnr134

    How to make Extension panel Compateble with Premiere Pro CC

    anoopnr134 Level 1

      Hi All,

      We are using Flash builder 4.6 and Extension builder 2.0 to make our Extension panel for Premiere pro CS6 applications and they are working fine.

      Now we need to extend this facility to Premiere pro CC application, we have tested these panel earlier in Premiere pro CC about a month ago and it  was working fine in the Premiere pro CC. But now we have tried to install our extension (.zxp) in different machines which is having the latest Premiere Pro CC in it, the panel is showing as an installed one in the Adobe Extension Manager CC, but in the Extension menu we are not able to see our panel.

       

      Can somebody help us with what can be the problem?

      We have downloaded Extension builder 2.1 trial also but it only an exe file and installed it in my machine which didnot made any difference.

      Is it possible to make an extension panel which will work fine in Premiere Pro CC using Flash builder 4.6 and Extension builder 2.0 or do we have to change our development environment?

      Please suggest.

        • 1. Re: How to make Extension panel Compateble with Premiere Pro CC
          lesavage Adobe Employee

          Hi,

           

          Can you share your manifest.xml file? This file is located in the .staged-extension directory inside your CS Extension Builder project. It is a hidden folder so you may need to adjust your Package Explorer filters to show hidden files in the Package Explorer.

           

          Also check that your manifest file is supporting Premiere CC by checking the HostList entries. Finally, check your manifest file to confirm that you have a <Menu></Menu> entry? This is used to display your product in the Window>Extensions menu. If this is empty or not available, the extension will not be added to the menu item.

           

          Kind regards,

          Lea

          • 2. Re: How to make Extension panel Compateble with Premiere Pro CC
            anoopnr134 Level 1

            Thank you for your immediate response. Here is the Manifest.xml

            Host version="[6.0,7.0]"

            and

            <Menu>eMAM</Menu>

            is there any other changes are needed?

             

            <?xml version="1.0" encoding="UTF-8"?>

            -<ExtensionManifest xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ExtensionBundleName="eMAM" ExtensionBundleVersion="1.0.0" ExtensionBundleId="com.example.eMAM" Version="3.0">-<ExtensionList><Extension Version="1.0" Id="com.example.eMAM.extension1"/></ExtensionList>-<ExecutionEnvironment>-<HostList><Host Version="[6.0,7.0]" Name="PPRO"/></HostList>-<LocaleList><Locale Code="All"/></LocaleList>-<RequiredRuntimeList><RequiredRuntime Version="3.0" Name="CSXS"/></RequiredRuntimeList></ExecutionEnvironment>-<DispatchInfoList>-<Extension Id="com.example.eMAM.extension1">-<DispatchInfo>-<Resources><SwfPath>./eMAM.swf</SwfPath> </Resources>-<Lifecycle><AutoVisible>true</AutoVisible></Lifecycle>-<UI><Type>Panel</Type> <Menu>eMAM</Menu>-<Geometry>-<Size><Height>200</Height><Width>200</Width></Size></Geometry ></UI></DispatchInfo></Extension></DispatchInfoList></ExtensionManifest>

             

             

            Also whenever we insatll the zxp in Extension Manager CC there an error comming up

            "You are about to install the extension, 'com.example.eMAM'. The publisher of the extension can not be verified, because the security certificate use by the extension hasn't been verified by a recognized authority. Are you sure you want to insatll this extension?" 

            Any issue with this one?

            Thanks

            • 3. Re: How to make Extension panel Compateble with Premiere Pro CC
              anoopnr134 Level 1

              Hi,

                  

                   Can you please replay what we need to do to make our panel working in the Premiere Pro CC?

                   We are waiting for your valuable comments.

               

              Thanks and Regards,

              Anoop NR.

              • 4. Re: How to make Extension panel Compateble with Premiere Pro CC
                Hallgrimur Bjornsson Level 3

                Hi,

                 

                I recommend you use Extension Builder 2.1 to set up and then export your extension to ZXP. My bet is that it will solve your problems. I do not recommend use CS Extension Builder 2.0 to make CC extensions - that use case is not supported.

                 

                Best regards,

                Hallgrimur

                • 5. Re: How to make Extension panel Compateble with Premiere Pro CC
                  lesavage Adobe Employee

                  Hi,

                   

                  You may need to adjust you Host Version entry to:

                  Host version="[6.0,7.9]"

                   

                  This will ensure that you panel loads in all 6.X and 7.X versions of Premiere. Alternatively, have the following entry:

                  Host version="6.0"

                  which means that the panel will load in all Premiere versions starting with 6.0

                   

                  I also recommend Hallgrimur's suggestion of using EB 2.1 to ensure that you are signing your extension correctly as part of the export process.

                   

                  Kind regards,

                  Lea

                  • 6. Re: How to make Extension panel Compateble with Premiere Pro CC
                    anoopnr134 Level 1

                    Hi,

                     

                         Thank you for your immediate replay.

                     

                         1. How to edit this manifest xml? can we manually edit it after installation? or in the Bundile manifest Editor in Flash builder?

                               In flash builder manifest.xml tab, cannot be modified, where to make the change inorder to make the host version 6.0,7.9?

                              In bundile tab, max target version has only 5,5.5 and 6.

                     

                    Thanks and Regards,

                    Anoop NR

                    • 7. Re: How to make Extension panel Compateble with Premiere Pro CC
                      Hallgrimur Bjornsson Level 3

                      Hi,

                       

                      You can manually edit it outside of Flash Builder, using any text editor.  You can also edit it using the Bundle Manifest Editor but you need Extension Builder 2.1 for that. Extension Builder 2.0 is not compatible with any CC product.

                       

                      Best regards,

                      Hallgrimur

                      • 8. Re: How to make Extension panel Compateble with Premiere Pro CC
                        anoopnr134 Level 1

                        Hi,

                         

                             Thank you very much for your kind responses.

                             We have edited the xml maually and now it is working in CC products.

                             We are trying to install 2.1 in our environment but there are some issues during installation. we are in toch with Adobe to fix   those issues.

                             But for now our panels made from 2.0 is working in Premiere Pro CC also.

                         

                        Thanks once again,

                        Anoop NR